Help - Search - Members - Calendar
Full Version: 130 Tdci 03 Acceleration Pulse
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
Snapper
Commuting yesterday and over 2800 rpm in 4,5,6th gears I felt a strange pulsing , it felt like torque was on/off enough to make me aware.
Speedo was climbing steadily as was the Tacho, but there was a definate slow pulsing in torque delivery.
Where do I start looking? Wastegate, EGR?
mintalkin
i would start with an egr valve cleanout,its a messy job but worth it, this link will help
http://www.fordwiki.co.uk/index.php?title=EGR_Valve_and_Inlet_Manifold_Clearout_TDCi
also check the intercooler hose which is the big hose from the bottom of the egr valve for any splits,and for any splits in the rubber vacume hoses.
Snapper
Yep, EGR to intercooler pipe 2" split just where you can't see it.
Saw what looked like a big patch on a near by pipe, air blowing from the split.
Did not have any silicon pipe or joiners in the workshop so had to pay Fords 54 for a 300mm bit of pipe, robbing *##*$DS
mintalkin
has the new pipe done the trick and stopped the pulsing?
Snapper
Will find out tomorrow, finished the job on the car then went down the pub to watch the England Ireland rugby.
For me not a good day and I owe Irish Mick a pint


Full Colour Version: 130 Tdci 03 Acceleration Pulse
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.