Help - Search - Members - Calendar
Full Version: Mondeo Tdci - Dark Smoke & `safe` Mode` Comes On Under Load/acceleration
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
stuu56
Hi Folks,

After ongoing issues with my car and the dreaded flashing glow plug light, the diesel specialist garage has said that it is the boost pressure wastegate which is the problem. They have said that they cant be bought separately and Ford will only sell it alongside a new Turbo unit for 1000. Is there any alternative to having to do this - can the pressure sensor or whatever be accessed?

Also, what are the symptoms if a Map sensor is faulty on a mondeo tdci?

Thanks,

Stuart
mintalkin
i presume that the car is showing error code P132A or P2263.first thing to check is that the varible vanes in the turbo are not clogged up with gunge,disconnect the arm from the actuator and see if it moves freeley if it does the vanes are allright.if the actuator is the problem these can not be bourght on there own.someone on ebay was offering a repair service but has dissapeared, so they can be repaired but i do not know how.


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615