Help - Search - Members - Calendar
Full Version: Galaxy
Ford Owners Club - Ford Forums > Ford Models > Ford Galaxy Club
Hutcho
Just curious if anyone else has had this problem or a similar one:

Everytime I stop in traffic, whether it is to stop at traffic lights, in a traffic jam or even a roundabout the cooling fan kicks in and stays running for the duration of my journey, (long or short), I've also noticed that the temp gauge on the dash doesn't move anymore, (the two maybe connected). I've checked water levels etc, everything seems ok. I have spoke to a ford mechanic, he had never heard of this fault before.............
mintalkin
sounds like you could have a dodgy temp sender.
delboy
hi m8

try the following as i had the same problem

open bonnett & on the rh side there is a large pipe with a connector attatched to it
it comes of the top of the rad the pipe does m8

remove the wires & fit them on the lower connector on the thermostat housing
swap them over as they are the same connectors
mine was crossed & i had the same happening
one is the fan switch & the other is the thermostat for the needle on the dash


Full Colour Version: Galaxy
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615