Help - Search - Members - Calendar
Full Version: Focus Bad Earth
Ford Owners Club - Ford Forums > Welcome to Ford Owners Club > General Chat
Chap84
Hi all my first proper post so a little new to it all. My problem is iv got a bad earth on the a/c condenser relay? But iv checked the fuse's, switched the a/c and horn relay and no problem with that? Iv went thru about 7 sets of headlight bulbs recently as they keep blowin!. A/c is working but not cold, and engine management light is on error it come back with is " a/c condenser relay bad earth" . Focus ghia 1.6 mk2. Thanks
Dan62
Sounds like you've got real problem.
My suggestion would be;
Disconnect the battery.
Check all main (high) power connectors at places like the battery, alternator and starter motor that they are secure and not corroded, check earth straps between the vehicle body and the engine.
Reseat ECU connector.
Reconnect battery and try again.

ECU fault code for a bad earth is a bit suspect as the ECU provides the earth for the relay, i'm sure coupled with the blowing headlamp bulbs the problem is more power related. The AC operating but not blowing cold may be related but probably its needs a gas recharge.

D.
Chap84
Thanks for the reply. Iv check the earths and all but 1 looked ok, so cleaned the bad 1 and reconected checked voltage and it's fine. So I went to get it regased & when they checked it was already full? So the guy starts to check the system and says the compresser and condenser are ok. He said he have to have a look tommorow but it is a bad earth he will just take a couple of hours to find( at 30 per hour) plus labour to fix.


Full Colour Version: Focus Bad Earth
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.