Help - Search - Members - Calendar
Full Version: Flat As A Witches ???
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
mik3b
hello there
i was wondering if anybody could help me. i have just bought a mondeo 2.0 130bhp for a family car had a transit before that anyway.
it has had a new turbo fitted allegedly and it required inter-cooler cleaning as it was smoky.but it lacks turbo power or should i say none, it couldn't pull the skin off a cow turd. i have serviced it fully and it has passed its mot today as well but i just cant get my head round why it is not doing anything all help would be greatly appreciated

mike :D
how does this work then
my 130 bhp went like the dog nadgers ,very fast car ,until turbo blew up (see previous forums),i would get it checked out proper and quick before you end up wiv a empty wallet!!!!
mintalkin
check to see if the inter-cooler pipe from the bottom of the egr valve is split,also if the turbo has the electronic actuator check to see if the arm is moving when the car is started,it should move forward and back for a second,finally check all the vac pipes are good and sound.
mik3b
wright got codes read and they are

p0235 boost sensor
p0403 exhaust gas control circuit
p0243 turbo waste gate solenoid

but i dont now were they are on vehicle any help would be great :D
mintalkin
it sounds like a faulty or gummed up egr valve,has this been cleaned lately ?
mik3b
did give it a clean but it was rely bad will give it another goin over


Full Colour Version: Flat As A Witches ???
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.