Help - Search - Members - Calendar
Full Version: Miss Firing
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
Marshall
Hi all,

I have a Mondeo MK3 1.8 which was miss firing at low rev's... about 7 months ago.. I changed the coil pack, plugs and leads... and it was fine for the 7 months, but has started to miss fire again.

When I originally had this problem... it was only when I changed the leads it was cured... They weren't ford leads... I've heard the Mondeo's eat lower market HT Leads.

Has anyone else heard this and If so which make of leads would you advise??

Many Thanks
stef123
[quote name='Marshall' timestamp='1307959679' post='131566']
Hi all,

I have a Mondeo MK3 1.8 which was miss firing at low rev's... about 7 months ago.. I changed the coil pack, plugs and leads... and it was fine for the 7 months, but has started to miss fire again.

When I originally had this problem... it was only when I changed the leads it was cured... They weren't ford leads... I've heard the Mondeo's eat lower market HT Leads.

Has anyone else heard this and If so which make of leads would you advise??

Many Thanks
[/quote]

Had very similar trouble with my focus quite a few times and again like yourself believe it to be lesser quality parts..

fitted genuine coil, plugs and leads and never a spot of bother again :)


Full Colour Version: Miss Firing
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.