Help - Search - Members - Calendar
Full Version: Trip Meter Not Working
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
Richardhart90
Hi all,
I've just bought a focus 1.8 Tddi and i cant seem to get the trip meter to work !
I've pushed the reset button but it just wont count as i drive.

Any help would be apreciated.

Thanks
Richard
mjt
Is it stuck at zero? If so I would suspect that the button or the switch it operates is stuck in.

I assume the speedo is working ok and the ordinary odometer is clocking up?
Richardhart90
[quote name='mjt' timestamp='1308477340' post='132380']
Is it stuck at zero? If so I would suspect that the button or the switch it operates is stuck in.

I assume the speedo is working ok and the ordinary odometer is clocking up
[/quote]

Hi,
Thanks for reply, the speedo is working ok and odometer is clocking up, i wonder if the reset button is stuck in , as i done the Self-Diagnostic Mode - Instrument Cluster test once and i cant seem to do it anymore !

How do releive the butotn?, when you push it in, it does seem to click when pushed?


Thanks
Richard
mjt
It does sound like a switch problem although if it clicks it may not be stuck so might be broken internally. I'm afraid I can't be more help as I've never had an instrument cluster out. If it's a surface-mount component it might not be feasible to replace it.

Hopefully someone else may be able to offer more help.
artscot79
[quote name='mjt' timestamp='1308480622' post='132387']
It does sound like a switch problem although if it clicks it may not be stuck so might be broken internally. I'm afraid I can't be more help as I've never had an instrument cluster out. If it's a surface-mount component it might not be feasible to replace it.

Hopefully someone else may be able to offer more help.
[/quote]

indeed its part of the internals of the cluster and wont be fixable well you can but 9 times out of 10 you break the cluster so ide get a new cluster from a scrapyard if it bothers you or just live with it and see if it pops out on its own


Full Colour Version: Trip Meter Not Working
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615