Help - Search - Members - Calendar
Full Version: Mondeo Tdci 130 Hissing (Video Too)
Ford Owners Club - Ford Forums > General Forums > Maintenance / Servicing / MOT Discussions
Stevetdci130
Hiya guys, im completely new to the forums and new to Mondeo's, had my 02 plate mondeo for around 3 months now, and i had a bump and the front re-enforcement bar went into the intercooler, the intercooler was slightly damaged due to this, several of the intercooler fins were bent in, now 3 weeks after the crash a hissing noise has developed only under acceleration, does anybody have any advice?

Here is the video: http://www.youtube.com/watch?v=8fBgHzwVf78

It sounds like air escaping but i cannot locate where from ?

Regards Steve
fish4tea
[quote name='Stevetdci130' timestamp='1308516223' post='132497']
Hiya guys, im completely new to the forums and new to Mondeo's, had my 02 plate mondeo for around 3 months now, and i had a bump and the front re-enforcement bar went into the intercooler, the intercooler was slightly damaged due to this, several of the intercooler fins were bent in, now 3 weeks after the crash a hissing noise has developed only under acceleration, does anybody have any advice?

Here is the video: http://www.youtube.com/watch?v=8fBgHzwVf78

It sounds like air escaping but i cannot locate where from ?

Regards Steve
[/quote]
get a jug of water and put some washing up liquid in it, stir it up a bit and then paint with a soft paint brush over the suspect area while engine running and look for the bubbles
wazza tdci
hi i had the same problem mine was the boost pipe from egr valve it had a hairline crack in pipe lift up bonnet bottom left of engine cover,lift cover off and you will see egr valve its the big pipe attached to the bottom of valve
jonboy01
my mate had the same car and he too thought it was the valve, had it replaced(not cheap i might add.....) and it didnt solve the problem.
turned out to be the big hose running to the turbo had a split in it.when the turbo was drawing air in it collapsed and drew air in from outside the car.....check your hoses first with the engine running,run your hands over them and give them a squeeze..might not be your problem but quick and easy to rule out. ;)


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615