Help - Search - Members - Calendar
Full Version: Problems With Sony 6Cd Multi Changer
Ford Owners Club - Ford Forums > Welcome to Ford Owners Club > General Ford Related Discussions
tucker
hi, ive got a problem with my sony 6cd multi changer in our mondeo, when i press the eject button the screen says that there are no cds even tho the are 6 in it, is there anything that can be done to sort this problem or is it buggered? any help or advice would be much appreciated.
Mr Ford
You could try unplug the radio or disconnect the battery for a few minutes this may reset the radio, but make sure you have the radio code. If it doesn't work go to your local ford dealer andd they could give you a quote to have it repaired or replaced or try a good In Car Entertainment and Security Specialist they could remove the radio and have it repaired.
tucker
thanks for the info, i'll have a look today and see what happens, thanks
mintalkin
this is a common problem when you put 6cds in, you may find that you have to remove the unit and strip it to gently remove the cds one by one.
tucker
thanks i'll try that, any idea where i'll get the tools to remove the cd player?
mintalkin
cheapest and best bet - ebay
tucker
thanks for the help much appreciated,
Magenta
Had this problem several times with my son's Mondeo estate with the autochanger in the boot. Had to strip it down several times to get the cd''s out. No special tools needed but it is quite a fiddly job. Try simply unplugging the power lead (after removing the cover)and then powering up again. This worked for us a couple of times but the problem came back eventually.


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.