Help - Search - Members - Calendar
Full Version: dash digital read out
Ford Owners Club - Ford Forums > Ford Models > Ford Fusion Club
nungy01
hi,

i am new to this website, i have just bought at 56 plate ford fusion 1.4, i have just noticed the ABS warning light has just come on and the brake warning light came on whilst driving and the centre of the dash where the milage read out is went blank, it just showed lines on the display instead of the milage. i believe the care is still under fords 3 year warranty can any one confirm this? and will ford put this right?

thanks for you help
hendrix
Hi there mate.welcome. if the cars first registered date (will be on dvla owners document v5) is within 3 yrs and car has been serviced correctly ( i.e. book stamped) should be covered take it in to fords. let us know how you get on. love my fusion its perfect for us shame things like this go wrong happens to all makes models i suppose.
nungy01
[quote name='nungy01' post='8638' date='Dec 19 2008, 06:40 PM']hi,

i am new to this website, i have just bought at 56 plate ford fusion 1.4, i have just noticed the ABS warning light has just come on and the brake warning light came on whilst driving and the centre of the dash where the milage read out is went blank, it just showed lines on the display instead of the milage. i believe the care is still under fords 3 year warranty can any one confirm this? and will ford put this right?

thanks for you help[/quote]

thanks for the reply, the car still has ford warranty until 0ct 2009 but now after being out in it today the engine sign has just come on and the car made a grinding noise as i pulled up outside my house, lets just hope Ford put it right cause if they dont then its going back to the garage i bought it from for them to do it, cause i aint paying.
mintalkin
sounds like the pads are worn putting the wear sensor light on.
nungy01
[quote name='mintalkin' post='8681' date='Dec 20 2008, 08:38 PM']sounds like the pads are worn putting the wear sensor light on.[/quote]

i dont think its the pads cause as i was driving the car the speedo just shut down basicly it went to zero even though i was still driving at about 50mph...i was just thinking it might be something to do with the computer or engine management system.
Potnoodle
Hey did you get to the bottom of this one?

My 03 plate fusion just came back from having a new clutch fitted and I've got the same problem.

Speedo is dead and readout just shows dashes. The battery must have been disconnected while the work was being done as the time was wrong on the clock and the stereo needed the code putting in when I had it back. I've checked the 2 fuses that correspond to the instruments but they're fine. Have unplugged and reconnected the cluster as well but it's still the same.


Full Colour Version: dash digital read out
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.