Help - Search - Members - Calendar
Full Version: Soft Top Problems :(
Ford Owners Club - Ford Forums > Ford Models > Ford KA / StreetKA Club
Elfy
Hello

My girlfriend is having probloems with the soft top storage compartment not opening when pressing the button. I have searched through the forum and have seen people have said to check the fuse/relay which i have done(not with a new one), checked the button connections etc.

It does not even make a noise when the button is pressed. Any ideas on what the problem could be? How much we are looking at to get it fixed? Or any help on where to find a new relay?

Any help much appreciated!

Alex
COSTESSEY GEOFF
Hi Elfy my wifes streetka proloem with storage compartment but hers made a noise when button pressed but not opening main ford dealer put new arm in ok now
Elfy
hmmmmm thank you. tested the button and the fuse and there seems to be a current. No noise when button is pressed though! Going to ford tomorrow to ask just hope its not expensive. I'm thinking its the motor in the boot that you can see!
M@ddog
[quote name='Elfy' timestamp='1312131168' post='138096']
hmmmmm thank you. tested the button and the fuse and there seems to be a current. No noise when button is pressed though! Going to ford tomorrow to ask just hope its not expensive. I'm thinking its the motor in the boot that you can see!
[/quote]


I too had the exact problem as you. The solution for me was to make sure the boot is slammed shut before pressing the hood compartment release switch. If the boot isn't shut correctly it won't let power reach the roof compartment switch. It is a safety feature to avoid a collision between the two.

Hope this helps

STK
Elfy
Thanks for the advice.

We have a result for anyone else with problems. We tried all the above, making sure the boot was shut properly, tested the fuse, tested the actual button to pop the boot etc.

Took it to a ford garage and the problem was the connection that goes to the boot catch. If you open the boot and look at the boot catch there is a little blue connection point. Ford wedged a bit of card to keep the connection in place, shut the boot and the the soft top compartment opened without a problem.

This was only temporary as we needed a new connection plug thing which i beleive in total with labour was 80 to fix.

Hope this helps anyone else with problems in future, wedge some card by the blue connector to keep it in place and shut the boot to see if the soft top part opens, if not then like everyone else has said, check the fuse, button, and make syre the boot is shut


Full Colour Version: Soft Top Problems :(
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.