Help - Search - Members - Calendar
Full Version: Engine Systems Fault - Help?
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
goaty
Hi. I have only had my Focus for over a week ( Diesel 06 plate 1.8 tdci zetec climate) and it seems to have a debilitating fault already!

We had clocked up 850 miles already with no problem (80% motorway/national speed limit A roads) when yesterday the dash displayed as "Engine System Fault" with a slight judder and speed reduced. I was only doing 55 mph in 5th and able to pull in quickly. Turned ignition off & back on and warning had gone and drove another 35 miles in total that day with no further problem. However tonight coming back from work it happened again when I was doing 35mph in 3rd. I pulled over, switched off and on & carried on for 10 miles before it did it again in town.

Has anyone else experienced this? I have heard it could be the sensors, egr valve or throttle body? Is this a common problem with the Focus? I seen on some forums that people have complained of very poor wiring.

I have a 3000 mile / 3 month warranty (well a shiny book they gave me and the promise on their website that all their cars are sold with this) so I am hoping they will have a look and fix it. Any advice appreciated & thanks in advance.
Leemaxd
My 1.8 tdci did judder now and again, and loses power, when it does I clean the egr valve and it sorts it, it gets clogged up soot, so if I were you look at that first.
I usually just put some spray through it but it doesn't last, the best way is to take it right off and clean it proper and it will last alot longer.
My mechanic takes mine off and gives it a good clean for 50.
jeebowhite
Agree with Leemaxd check the EGR valve and clean / replace as necesary. Also check the fuel filter is not gunged up, or even leaking to allow air into the system that can cause a problem, otherwise check the DPF isnt present, and if it is, get it regen'd or replaced as necesary.
goaty
Thank you both. My girlfriend took it back to the dealer on Friday. They hooked it up to a computer and found a few error codes but couldn't tell if these were recent or old ones. They gave it a test drive and it was fine but ended up putting in some fuel cleaner to hopefully resolve. We did 180 miles since and it has been fine.

I am still keen to get the EGR valve clean so can you recommend a good place to get the Wynn's cleaner? I popped into Halfords but they don't stock that particular product despite doing quite a few other items by Wynn. Cheers
jeebowhite
I think you might find it worth looking on ebay, you can get it there for a reasonable price. Otherwise, EuroCarParts or similar may do it...


Full Colour Version: Engine Systems Fault - Help?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.