Help - Search - Members - Calendar
Full Version: Electric Power Steering Pump Whine
Ford Owners Club - Ford Forums > Welcome to Ford Owners Club > General Ford Related Discussions
Bartman
Hello,

I have a 55 plate Focus Cmax Ghia Titanium, the problem I am hoping that the forum members can help me with is the Electric Power Steering Pump has a whine its there straight away when the car is started up and it can be heard slowing down after the ignition is switched off. I am sure this is the problem as it the noise cannot be heard when the power supply is pulled on the unit, can the unit be serviced? fluid level is ok.

Thanks For looking
Lenny
[quote name='Bartman' timestamp='1314981305' post='142521']
Hello,

I have a 55 plate Focus Cmax Ghia Titanium, the problem I am hoping that the forum members can help me with is the Electric Power Steering Pump has a whine its there straight away when the car is started up and it can be heard slowing down after the ignition is switched off. I am sure this is the problem as it the noise cannot be heard when the power supply is pulled on the unit, can the unit be serviced? fluid level is ok.

Thanks For looking
[/quote]
Could be the bearings are worn in the cog that the belt turns,


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615