Hi

Sorry for the cheesy title but hoping someone can help...

I've owned my 57 plate 1.8 Tdci Focus Style for a year, bought with full service history, 58k on clock. My first owned diesel (had diesel company cars previously but then they were some one elses problem!)

Its been running brilliant and still is just it's developed a strange noise over the past 3 months but it only happens now and then but has been increasing in frequency the past month.

This is what happens,

Start the car no noise,trips around built up areas (stop/start) no noise even when engine is at optimum temp and going through gears changing at 2000-2500rpm.

Cruising speed on A road/Motorway for couple miles, revs up to 2000-2500, slow down for roundabout or stop for junction, when i pull off again the noise starts a whoooooooooing noise as i go through the gears from 1st to 5th, stops as i leave off accelerator to change then starts in the next gear. Its stops as soon as ive built up speed again or if i slow/stop the car and pull off again.

Only thing is this doesn't happen every time. I can go on a long journey and it may happen once. Or it may happen 2-3 times on a shorter journey.

Mechanic took on test run and it didnt happen, Ive checked pipes going in and outa turbo can't see any leaks. Mechanic seemed to think turbo maybe on its way out but until he hears the noise cant tell for sure because car is running fine, no loss of power, exhaust smoke etc

Could this the build up to a major problem. New turbo sounds like a financial crisis at the moment.

Any ideas or if some one has similar problems, replies would be gratefully appreciated. (Apologies for the essay!)