Help - Search - Members - Calendar
Full Version: Aww Jeeez Had The Mondeo 2 Months...
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
Tori
Bought the mondeo in july, to last me 12 months, stick 40k on the clock and replace with a nice shiny new car....
problem 1.... no reverse lights- reverse switch replaced
problem 2.... struggled sooo hard to get into reverse, some adjustment made by my mechanic
problem 3.... really loud knocking noise from engine- cam tensioner pulley replaced in june with non gen part.. i replaced with gen part- running like a dreammm

problem 4.... if accelerating in 6th gear, flashing glow plugs
problem 5.... engine management and flashing glow plugs randomly coming on and problem accelerating and no turb
problem 6.... took the car to the garage today, car plugged in fired up a fuel fault code, fuel lines changed fuel filter sorted. everything flushed.



5 miles later. car was D E A D... great one. tori the rep out of action
AA man has diagnosed with fuel pump or injector. I have never had so many problems with a car!!!!!

will update on my poor sickly mondeo who will be part exchanged for a VW if its still gonna be naughty in a few months time lol
Lenny
[quote name='Tori' timestamp='1316464538' post='144840']
will update on my poor sickly mondeo who will be part exchanged for a VW if its still gonna be naughty in a few months time lol
[/quote]

Hope it get's sorted out for you and Perhaps change where you buy your diesel too.
Tori
looks like its the fuel pump... :-/ 1000 minimum


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.