Help - Search - Members - Calendar
Full Version: Ford Mondeo Tdci 06 Reg
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
marrak1967
Hi there i have seviced my 06 tdci mondeo zetec and now noticed that it was starting to take longer to start in the morning so i thought it was the battery but no it still struggled to start even after new battery.I did notice that there was some black smoke when driving but today it would not start at all.any thoughts super techs.i spent alot of money getting it back on the road as it was damaged and dont want to spend loads more.many thanks michael
mintalkin
it could be a stuck open egr valve, remove and clean the valve and see if things improve.
marrak1967
ok mate will check this thanks.
marrak1967
checked egr valve and cleaned still the pig would not start but after i jumped it from other car it fired up.took it for a drive still smokie thought i heard a little rattle from engine this is new.when driving it still feels plenty of power.when it would not start the eng/mang/light was on and then flashing glow plug.the egr valve seamed free. but dont know if the valve is meant to be fully open or in closed postion when i checked it as i can push the valve up ?.any help much app,michael.
marrak1967
Update as usual mondeo would not start so checked out the forum and some people suggested that either the camshaft sensor or the crankshaft sensor so today i changed both and car is still struggling to start.anybody got any other ideas i have pulled out the rest of my hair out.many thanks now baldy michael.


Full Colour Version: Ford Mondeo Tdci 06 Reg
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.