Help - Search - Members - Calendar
Full Version: Heater Blowing Hot
Ford Owners Club - Ford Forums > Ford Models > Ford KA / StreetKA Club
stansoldman
Hi guys, Just change the HCV on my daughters 04 Street Ka as the heater was blowing constant hot air. This has not worked. Checked the plug onto the HCV to see if there was 12V, No. Is there a fuse or is it another problem. Hit a brick wall and need some help. Thanks Guys
M@ddog
Same happened to our StreetKa - Almost certainly the Heater Control Valve. They are prone to fail and they either Stick in the hot or cold position. Your best bet is to get one from Ebay, the cost is only about 15 (they are a generic ford part for all MK1 KA's and transit vans etc so there's no need to find one specific to the StreetKa)Changing it is pretty easy takes about 30 mins. If you need step by step instructions to do this please let me know!

Hope this helps!

Andrew
stansoldman
[quote name='M@ddog' timestamp='1317542054' post='146651']
Same happened to our StreetKa - Almost certainly the Heater Control Valve. They are prone to fail and they either Stick in the hot or cold position. Your best bet is to get one from Ebay, the cost is only about 15 (they are a generic ford part for all MK1 KA's and transit vans etc so there's no need to find one specific to the StreetKa)Changing it is pretty easy takes about 30 mins. If you need step by step instructions to do this please let me know!

Hope this helps!

Andrew
[/quote]
Thanks Andrew. Replaced the HCV yesterday. Did not cure the problem. I tested the valve and i am not getting a 12v signal. so i think it might be the heater controls.
btmaldon
Was it not giving you 12v in both the hot and cold position with the engine running?

If so like you said it is most likely the Heater Control Panel which is attached to the rear of the heater control knob. It may be cheaper to buy the whole panel from a scrappy or eBay. I managed to get one for our old Puma for 5 and the control panel was working fine.
stansoldman
Thats the next step, just about to go onto fleabay and have a mooch for one.
Thanks for your help
stansoldman
Ok I have now replaced the heater controls and the HCV but i am still getting hot air. I dont seem to have any 12v feed to the HCV
I cant locate the feed or the fuse for the HCV...... Need a little help please.


Full Colour Version: Heater Blowing Hot
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.