Help - Search - Members - Calendar
Full Version: Sierra 2.0I Efi Wont Start
Ford Owners Club - Ford Forums > Ford Models > Ford Sierra Club
sportiva.t35.com
Hi!
The problem is s the title says. The car is model a year 1991 2.0i OHC (PINTO) engine with EEC IV EFI with HEGO (lambda) and catalytic converter (witch BTW was removed by the previous owner). The car runs on petrol and LPG. Before the problem the car had some hesitation when accelerating while driving on petrol and on LPG was running fine.

Yesterday I was fitting a new rear exhaust silencer. After I welded the silencer I turned the engine on to check if the weld was good. The engine did run fine. After that I lowered the car and removed the jack stand. Tried to start the engine again and now the engine cranks but wont start either using petrol or LPG

I checked the ignition by pulling a spark plug wire off of a spark plug and placed the open end of the plug wire near a metal surface on the engine. My m8 cranked the engine while I watched for a spark and there was sparks.

When the LPG system is switched to petrol and I turn the ignition key I hear the pump working and when I switch to LPG mode I hear the LPG solenoid open.

My guess is that the compression is OK as the timing belt is in place.

Any suggestions on what could be wrong?
sportiva.t35.com
Changed the spark plugs and now it runs OK :)


Full Colour Version: Sierra 2.0I Efi Wont Start
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.