Help - Search - Members - Calendar
Full Version: Quick Clear Earth Strap
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
Flis45
We had a windscreen replacement co round to replace the front screen on our Mk 1 Focus, which has Quick Clear. The guy said that the bolt used to earth it was missing, and we would need to get one before he could reconnect it properly. It is located under the plastic housing containing the courtesy light, which they replace, because apparently they often break. So he was reluctant to fit the screen and then fix the Quick Clear later.

Does anyone know what this should be, and if possible a part number for it?

Thanks!
Parf
I have a similar problem on my MK2. The quick clear wasnt working and when i checked a new screen had been fitted and the person who fitted it didnt even connect the cables. I connected the right and left connector but it still does work. The fuses are fine and the relay clicks when the button is pressed. Is there an earth somewhere that also needs connecting?
sjwred
[quote name='Parf' timestamp='1317980786' post='147412']
I have a similar problem on my MK2. The quick clear wasnt working and when i checked a new screen had been fitted and the person who fitted it didnt even connect the cables. I connected the right and left connector but it still does work. The fuses are fine and the relay clicks when the button is pressed. Is there an earth somewhere that also needs connecting?
[/quote]
Check inside the left and right connecters coming from the loom (not the w/s ones) see if they are clean and not a corroded blue colour,if you can get hold of an electrical reader see if you have power going to to those leads,the TDC strap(gold strap) is indeed above the courtesy light,that connection must be clean and tight ,if loose it an spark and could cause a fire,on the newer Foucus like mine 2002 model there is 1 connecter at the centre down the bottom of the w.s and 1 by the courtesy light. The engine HAS to be running to get the heated w/s to work
sjwred
[quote name='Flis45' timestamp='1317650765' post='146890']
We had a windscreen replacement co round to replace the front screen on our Mk 1 Focus, which has Quick Clear. The guy said that the bolt used to earth it was missing, and we would need to get one before he could reconnect it properly. It is located under the plastic housing containing the courtesy light, which they replace, because apparently they often break. So he was reluctant to fit the screen and then fix the Quick Clear later.

Does anyone know what this should be, and if possible a part number for it?

Thanks!
[/quote]
I hope it's just missing and not snapped off,ring any ford dealer explain where the bolt is and that should do it.the courtesy light comes off quite easy ,use a torch to see if bolt is missing or broken off,tuck earth strap away from any metal surface until it's fixed. If bolt is snapped off it will need to be drilled out and re-tapped I suggest by a garage.
Parf
Thanks for the advice sjwred. I just tried to remove the courtesy light and it doesnt want ot move. I dont want to force it incase i snap something. The housing appears to be screwed but i cant get to the screws without removing the light cluster.
Parf
Finally got it out and you were right sjwred the earth connection was there. The idiot who fitted the new screen didnt bother connecting it, the old one was still attached and had been cut to get the old screen out. The new screen earth strapped was just tucked in by the headlining. Ive connected it all up now, including the power by the wipers as they didnt even bother connecting them up either. All i need now is a cold morning so i can test it.

Thanks for all your help.
sjwred
[quote name='Parf' timestamp='1318238043' post='147744']
Finally got it out and you were right sjwred the earth connection was there. The idiot who fitted the new screen didnt bother connecting it, the old one was still attached and had been cut to get the old screen out. The new screen earth strapped was just tucked in by the headlining. Ive connected it all up now, including the power by the wipers as they didnt even bother connecting them up either. All i need now is a cold morning so i can test it.

Thanks for all your help.
[/quote]
sjwred
You can test it b4 it gets cold. Turn on heated w/s with engine running turn off blowers, the revs should drop a little as it uses a lot of engine power
Wait for 1-2 minutes touch the outside of the w/s near the black band and then touch the centre of drivers and passenger side with a flat hand, you should feel the difference
Parf
Looks like its finally working. There is a difference in temperature around the window.

Thanks for all help guys.


Full Colour Version: Quick Clear Earth Strap
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615