Help - Search - Members - Calendar
Full Version: 06 duratec 1.8 125hp
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
bigmc1087
hello there, i own the above motor which i use in dublin as a taxi,, i have been having terrible trouble with power loss lately, my engine management light came on, and when it was put on the diagnostic machine it pointed i the direction of the air flow system, now the symptoms
when the car has been running for a while the problem starts to come into it, as i take off the car pulls away normally, but when i go to give it power the engine just slumps, however if i tip the accelerator she will build up speed gradually, if i am travelling along m'way at say, 6o m.p.h. it will run normally for a few miles then it will start to slow down of it's own accord even with the cruise control on, when the car is stopped in neutral if i go to gun the engine it will rev right up and then die off to the point where it is spluttering and then backfires, however again if i tip the accelerator it will rev right the way up tp the red line, the ford garage mechanics are a pack of W&^*(%S and don't trust them one bit as the last time the car was serviced they left the used spark plugs under the bonnet, thankd in advance for any replies,
mmafighterlinc896
[quote name='bigmc1087' post='9217' date='Jan 4 2009, 06:46 PM']hello there, i own the above motor which i use in dublin as a taxi,, i have been having terrible trouble with power loss lately, my engine management light came on, and when it was put on the diagnostic machine it pointed i the direction of the air flow system, now the symptoms
when the car has been running for a while the problem starts to come into it, as i take off the car pulls away normally, but when i go to give it power the engine just slumps, however if i tip the accelerator she will build up speed gradually, if i am travelling along m'way at say, 6o m.p.h. it will run normally for a few miles then it will start to slow down of it's own accord even with the cruise control on, when the car is stopped in neutral if i go to gun the engine it will rev right up and then die off to the point where it is spluttering and then backfires, however again if i tip the accelerator it will rev right the way up tp the red line, the ford garage mechanics are a pack of W&^*(%S and don't trust them one bit as the last time the car was serviced they left the used spark plugs under the bonnet, thankd in advance for any replies,[/quote]


hi is there any signs of oil or water usage, you can also check the oil cap for a white residue which can indicate a head gasket failure, i had a 2.0l mondeo which had this problem and once i changed the head gasket it was fine, now i would say on the mondeo mk3 they , dont had a mass flow air flow meter unlike the mk 2's have, my v6 had one of these and that was the problem for that not been able to rev when it was stood it was fine but when the car was in motion it would rev slowly but when you gunned it it would backfire and die, it would re start ok. you can get a engine specialist to check your water with a special die that checks for head gasket problems some garages may also do this but very few where i live do this. the best things to do is check your spark plugs are working ok and leads etc as this can also cause a similar effect. hope this helps, without seeing the car i cant really help :rolleyes:
The Gardener
Hi!

I had a cavelier a few years back with very similar problems.

It turned out to be the exhaust back box disentigrating and stopping gases from being released.
I removed the box before buying a new one, started the car and drove loudly for a few miles and all was well!
You never know, this may be your problem.

Simon
stef123
do you know what the fault code was? and any description to go with the code.
The Gardener
[quote name='stef123' post='12359' date='Feb 16 2009, 11:18 PM']do you know what the fault code was? and any description to go with the code.[/quote]




No idea what the fault code was, all i did was remove the back box and after finding this was the fault i replaced the old box with new.

Simon


Full Colour Version: 06 duratec 1.8 125hp
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.