Help - Search - Members - Calendar
Full Version: Fiesta Help
Ford Owners Club - Ford Forums > Welcome to Ford Owners Club > General Ford Related Discussions
nirvanaboy
Hi all I have just bought a 52 plate ford fiesta 1.4 lx it runs fine apart from when the revs are low it splutters untill the revs pic up then its absolutely fine i have no idea whats wrong i have checked the spark plugs and the air filter not sure what it could be, the engine light is on i had it fault read and it said cat under efficency but i was told by the garage guy that that wont cause the spluttering any ideas guys
Danny87
It could be the idle air control valve, this is responsible for controlling the air intake when the engine is cold. They are known to get dirty and cause the issues you're having, is the problem worse when you start the car from cold?
nirvanaboy
it seems to be same all the time just at low revs really maybe a very very slight improvement when warm
stef123
[quote name='Danny87' timestamp='1317801644' post='147106']
[b]It could be the idle air control valve, this is responsible for controlling the air intake when the engine is cold[/b]. They are known to get dirty and cause the issues you're having, is the problem worse when you start the car from cold?
[/quote]

It is responsible for the idle speed whenever the throttle butterfly is closed, not just when its cold.

I suspect your car is misfiring, possibly due to a bad coil or leads


Full Colour Version: Fiesta Help
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615