Help - Search - Members - Calendar
Full Version: Thermostat Change Help
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
soulman123
No matter what the weather the car is taking 5/6 miles of driving to get to operating temperature. Which seems a bit long to me ? usually after 5 mins on other cars I've had it gets up to temp fine. Is this a normal warm up time for the focus or does this point to a dodgy thermostat ?

Is it a simpe to job to do the stat ? I did it on my previous car a mk4 golf, which was a case of draning fluid, taking the stat housing off and then replacing the stat o ring and putting it back together.

Maybe its a bit stuck causing these problems.

Its a cheap enough part I think usually about 10.

Are there any how-tos on it lurking about with pics ?

Thanks all.
jeebowhite
I believe kingfisher has had a lot of dealings with thermostat, as he has a similar problem, might be worth PM'ing him to see if he can help on this thread. as for the symptoms, sounds like it could be thermo related, and as such I have heard that replacement is not too difficult a process.
soulman123
Thanks for the heads up *thumbs up*

I'll send him a message.
jeebowhite
No Worries, hopefully he could shed a light or two that might help, he has a long thread somewhere on the forum... unfortunately I think he is still digging for the answer.


Full Colour Version: Thermostat Change Help
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.