Hopefully I'm posting this in the right section.#

I have a Ford Fiesta - Automatic 1997 1242cc. For several months the revs have been periodically dropping, whether I am at a constant speed, accelerating or breaking. Initially the revs were dropping from 1500 to nil then straight back up, now they are dropping by a couple of hundred revs at a time (so at least I'm not nearly thrown through the windscreen now). Diagnostics show nothing each time and the garage hasn't been able to find a fault. Once it completely stopped and the car wouldn't even turn over, after leaving it 20 minutes it suddenly decided to start again but the revs dropped to zero then back to 1500 constantly all the way to the garage, at that time the garage did find the water pump had broken but I was told that shouldn't have caused the problem with the revs.

Typically it never does it when the garage has it, even though over the past few months they have had it for several weeks trying it from cold in the morning, taking it for runs throughout the day etc etc. It has had a new fuel filter, two new coil packs (when replaced the first time it stopped doing it for a while so we weren't sure if the first replacement was faulty), new plugs and leads and a new air intake thing (can't remember what it is called) and another new part that sits close to that.

I've had the car from 3 years old and this is the only major problem it has had in all that time. I love the car and don't want to get rid of it (I only use it to and from work so it does less than 5000 miles a year) but is has got to the stage where my husband panics if I'm a few minutes later than expected in case I have broken down on the motorway.

Does anyone have any idea what is happening to it and how it can be rectified?