Help - Search - Members - Calendar
Full Version: Power Steering Fluid Black ?
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
panman40
Hi,
I think i posted in the wrong place earlier Lol !, This was my post if anyone can help please .

Hi there, i'm new here, I am hoping somebody can help me out please, About 18 months ago our 04 Focus TDCi 115 developed a steering fault and got trailered to the local Ford Garage, The powers steering fluid was black so the system was fushed out and new put back in, they were not sure if it's a Pump issue or a Rack.
Now its black again and the steering is not great to say the least !. If anyone can help me out as to which is to blame and if its a common problem etc i will be very grateful as my wife uses the car for work every day so i need to get something sorted asap.

Many thanks !
panman40
[quote name='panman40' timestamp='1322923895' post='155093']
Hi,
I think i posted in the wrong place earlier Lol !, This was my post if anyone can help please .

Hi there, i'm new here, I am hoping somebody can help me out please, About 18 months ago our 04 Focus TDCi 115 developed a steering fault and got trailered to the local Ford Garage, The powers steering fluid was black so the system was fushed out and new put back in, they were not sure if it's a Pump issue or a Rack.
Now its black again and the steering is not great to say the least !. If anyone can help me out as to which is to blame and if its a common problem etc i will be very grateful as my wife uses the car for work every day so i need to get something sorted asap.

Many thanks !
[/quote]


LOL, Damn quiet on here innit !!
TDCiST
Sounds to me like the seals in the pump, or the hoses for the system are breaking up...
artscot79
[quote name='TDCiST' timestamp='1323029538' post='155270']
Sounds to me like the seals in the pump, or the hoses for the system are breaking up...
[/quote]

its common and caused by the seals not breaking down but the rubber thats used contaminating the fluid my old foci had the same for years steering was fine though if the steering is bad then as stated it could be the seals in the pump
stef123
My old focus also had black p/s fluid, never had any issues with it though
panman40
[quote name='stef123' timestamp='1323093581' post='155306']
My old focus also had black p/s fluid, never had any issues with it though
[/quote]


Thanks Guys, So its more than likely the Pump then ?, thats great as i ordered one yesterday from ebay,

Cheers :)


Full Colour Version: Power Steering Fluid Black ?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.