Help - Search - Members - Calendar
Full Version: Help Needed Asap Ford Escort
Ford Owners Club - Ford Forums > Ford Models > Ford Escort Club
Londonguy123
hi! guys

im new to the forum

ive just bought a ford escort R reg 1.4 CL Estate

the problem i am having with it is;

the temperature gauge shots up every time i start the car, rather than moving up slowly to the middle and stay there it doesn't
can someone please advice me what i can do to fix this problem?

the car doesnt over heat, drives fine etc.. just the temperature gauge has me a bit worried
Lenny
[quote name='Londonguy123' timestamp='1324155377' post='156963']
hi! guys

im new to the forum

ive just bought a ford escort R reg 1.4 CL Estate

the problem i am having with it is;

the temperature gauge shots up every time i start the car, rather than moving up slowly to the middle and stay there it doesn't
can someone please advice me what i can do to fix this problem?

the car doesnt over heat, drives fine etc.. just the temperature gauge has me a bit worried
[/quote]


sounds like the temp sensor is done for mate,

should be no more than 20 to replace
mintalkin
it could also be the wiring to the sensor earthing out causing the gauge to move, so check the wiring to the sensor.


Full Colour Version: Help Needed Asap Ford Escort
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.