Help - Search - Members - Calendar
Full Version: Heater Control Valve
Ford Owners Club - Ford Forums > Welcome to Ford Owners Club > General Ford Related Discussions
old geezer
Can any body help me with the following problems? I have a 98 Fiesta 1.4 zetec and have some problems with the heater operation.
Firstly i replaced the HCV (not a ford part ) and bled the system and at first all was ok.Now the heater will only work on number4
and will only blow cold air.

If the HCV i bought was faulty would this cause the blower to only work on number 4 and only blow out cold air?
I have bled the system and both pipes going to the HCV are red hot, after the HCV the left pipe is red hot but the right pipe stays
cold.
I still cannot see the connection between the HCV failing and the blower only working on number 4 (if there is one).
My last problem is that i think my fan thermostat is faulty and am going to replace it tomorrow but
would this have any connection with all the probs above???

If you can help with any of the above i would be very grateful.
Thanks.
Preee
[s]The HCV if failed could produce only setting 4 , as a failed state they still have to produce a through put allowing the fan to work , usually the other settings are resistance type in a series format so if the element fails it cuts the first three fan speeds.

How ever not sure about the temp side of things[/s]

*EDITED responce* HCV was different to what i was thinking

Looking at the part it could well be faulty or an Air lock could be causing it
btmaldon
The blower only working on number 4 will be the heater resistor that has gone. Not sure where it is on the fiesta, but someone should be able to tell you. They are pretty cheap to buy

It does sound like you bought a faulty HCV and its stuck shut. Make sure the electrical connection going to the solenoid is good. You can also check the connections with a meter. The voltage should go up and down as you turn the heater control knob from hot to cold while you have the ignition on. If not the heater control panel may have gone. This is behind the heater knob.
old geezer
[quote name='Preee' timestamp='1325784903' post='159566']
[s]The HCV if failed could produce only setting 4 , as a failed state they still have to produce a through put allowing the fan to work , usually the other settings are resistance type in a series format so if the element fails it cuts the first three fan speeds.

How ever not sure about the temp side of things[/s]

*EDITED responce* HCV was different to what i was thinking

Looking at the part it could well be faulty or an Air lock could be causing it
[/quote]


Thanks for the feed back Paul
I am going to re new the HCV with a Ford one.

Andy
old geezer
[quote name='btmaldon' timestamp='1325798379' post='159621']
The blower only working on number 4 will be the heater resistor that has gone. Not sure where it is on the fiesta, but someone should be able to tell you. They are pretty cheap to buy

It does sound like you bought a faulty HCV and its stuck shut. Make sure the electrical connection going to the solenoid is good. You can also check the connections with a meter. The voltage should go up and down as you turn the heater control knob from hot to cold while you have the ignition on. If not the heater control panel may have gone. This is behind the heater knob.
[/quote]


That will be about right,i was trying to save abit of money when i got it of ebay.
Im buying one from FORDS now and looking into the heat resistor location.

Thanks for the advice.

Andy.
old geezer
Thanks for the advise.
Replaced heater control valve with a new one bought from fords,
and replaced the heat control resistor and all is GOOD.

Thanks again .
Andy
btmaldon
Glad to hear everything is sorted.


Full Colour Version: Heater Control Valve
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.