Help - Search - Members - Calendar
Full Version: Noise From Rear Suspension On Mkiii Mondeo Hatchback
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
J.R.
Hi all,I need your advice please....

I've just had my rear shocks & springs replaced on my MkIII Mondeo at my local garage. After collecting it I noticed an annoying noise from what appears to be the rear left shock (this noise was not there before and I only replaced the springs as they were badly corroded). It's almost like a knocking noise especially when driving on a bumpy road. I took it back to the garage where they checked everything and said it could be the anti-roll bar rubber bushes or the drop links. I made arrangements to take the car back next week but thought sod it, I'll change the bushes & drop links myself which I've done but the noise is still there.

Any suggestions / advice on what I should look at next?

Thanks!!
btmaldon
Sounds like the top mount has worn and therefore has some play in it which will give you the knocking noise.
pragmatix
Have you checked the exhaust, thats what the knocking was on mine
J.R.
[quote name='btmaldon' timestamp='1326040225' post='160109']
Sounds like the top mount has worn and therefore has some play in it which will give you the knocking noise.
[/quote]

I'll look at that next...it does sound like the noise is coming from the top of the shock. Thanks for your help.
TDCiST
[quote name='btmaldon' timestamp='1326040225' post='160109']
Sounds like the top mount has worn and therefore has some play in it which will give you the knocking noise.
[/quote]

agreed... by the sounds of it youve done everything else lol!
J.R.
[quote name='pragmatix' timestamp='1326040320' post='160111']
Have you checked the exhaust, thats what the knocking was on mine
[/quote]

Yep, checked the exhaust, handbrake cables etc - no problems. Thanks anyway!
J.R.
Thanks for all your suggestions...turns out it was the top mount which was causing the noise. All nice and quiet now! :-D
btmaldon
Glad its sorted, and thanks for coming back with an update
jj999
I too have a knocking noise which i suspect is the same problem, i'm assuming by the top mount , that this is the shock absober but how can i tell and what other places should i check


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.