Help - Search - Members - Calendar
Full Version: Been For A Diagnostics Test Today
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
1djspikey
Hi all :)

been for a Diagnostics test on my 2002 mondeo estate ghia 2.0 tdci euro 3 that goes into limp mode and glow plug flashing heres the codes ive been given :(

U1900 CAN Communication Bus Fault

P0100 Mass or Volume Air Flow Circuit Malfunction

P0235 Turbocharger Boost Sensor A Circuit Malfunction

P1665 Injection pump control module communications

P1664 pump control module malfunction

P1211 Injector Control Pressure Sensor Above / Below Desired engine running

P0251 Injection Pump Fuel Metering Control A Malfunction

i also had a vacuume pressure test on the EGR and was working well plus i did clean it all out a few weeks back so this problem was wiped off the list

the turbo is vacuume actuator as been tested and is running fine and turbo is not that old by the looks of it pretty clean B)

as anyone got any ideas and thoughts ?? :unsure:

regards spike ;)
Stoney871
You might find all those faults are caused by one sensor or connection playing up.
I'm wondering if a CANBUS error is the root?
I'm sure someone will be able to shed light on this.
TDCiST
oooh CANBUS fault! not seen that before...

Thats a lot of faults, surely if there is a CANBUS fault, it cant report other errors?? I'm confused!?!?
1djspikey
the car runs sweet till you need to boot the turbo in 3rd and 4th gear heres the print out

[img]http://i1020.photobucket.com/albums/af328/1djspikey/img002.jpg[/img]
oh for got to mention ive put half a tank of diesel in and forte advanced formula diesel treatment in tank as made response better but still goes limp
TDCiST
2002 diesel isnt it??

It could be that its not CANBUS compliant... My 2004 focus wasnt, would only do OBDII or whatever the other protocol was
1djspikey
yeah it`s 2002 euro 3 got all the vacuume valves on and egr right handside at the back
stef123
Can you get those codes cleared and see what reappears?
1djspikey
[quote name='stef123' timestamp='1327103049' post='162371']
Can you get those codes cleared and see what reappears?
[/quote]

Hi steff

The codes was reset 2weeks ago so these are resent codes over the past 2weeks if you know what i mean

spike
1djspikey
can you just replace FORD MONDEO MK3 TDCi FUEL METERING VALVE SENSOR
plus fuel pump tempeture sensor or do you have to recode them also can you just replace the top rail sensor or is the a recode :huh:


spike
mintalkin
diesels did not become eobd untill 2004 so unless they have the correct reader it could throw up all sort of codes hence the canbus error.
gmac187
Hey guys... Got a P2263 turbo/charger boost system performance fault.
Flashing glow plug but no ECU light
It's a 53 2.0 TDCi Ghia.. In limp mode at moment... Had egr off and cleaned. Been reading lots about this just wondered if anyone has had that same code before? If so, what is the best course of action? Thank you ...
stef123
[quote name='gmac187' timestamp='1345057539' post='201150']
Hey guys... Got a P2263 turbo/charger boost system performance fault.
Flashing glow plug but no ECU light
It's a 53 2.0 TDCi Ghia.. In limp mode at moment... Had egr off and cleaned. Been reading lots about this just wondered if anyone has had that same code before? If so, what is the best course of action? Thank you ...
[/quote]

have you checked the hoses for splits?
piper
[sup]Going for a diagnostic test tomorrow with pretty much the same problem , glow plug light comes on when i put my foot down (hard) and then the car goes into limp mode.[/sup]
[sup]It will re-set it self when i turn the engine off.[/sup]
[sup]It will be interest to see what come up, not much i hope. [/sup]


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615