Help - Search - Members - Calendar
Full Version: Glow Worm Light
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
frd2krd
hi i have a problem with my mondeo 2003 the glow worm light comes on when i am driving and the car begins to stutter and lose power any help please
rojariggs
The glow plus light on diesels can be used to represent any number of engine-related issues. Normally, these will be sensor/electrical/engine management related.

The stuttering and losing power is because the engine management system goes into a "limp home" mode when this light comes on. This is designed to stop you doing any damage to the engine until the problem is resolved.

Does it do this all the time or only when it warms up or you drive fast or any any other pattern you can identify? Does it resolve itself if you switch off, remove the key and switch back on again?
1djspikey
[quote name='frd2krd' timestamp='1328606750' post='165242']
hi i have a problem with my mondeo 2003 the glow worm light comes on when i am driving and the car begins to stutter and lose power any help please
[/quote]

Hi fred

are you able to go and get a Diagnostics test done to see what codes the car throws up.
ive a pretty bad time with my car but hopefully fingers cross it as been fixed at garage its in there now.

john
frd2krd
hi it starts up alright and i drive for a while then it comes on i stop the car and it goes away for a while then it starts again it seems to be when it is warm.thanks
1djspikey
[quote name='frd2krd' timestamp='1328610983' post='165248']
hi it starts up alright and i drive for a while then it comes on i stop the car and it goes away for a while then it starts again it seems to be when it is warm.thanks
[/quote]

yeah i had the the same problem and you may get it more when you put your foot down more when the turbo boost kicks in more
mostly from 3rd gear upwards the problem will never go away.
so you do need a Diagnostics test done would pay to go and get one done try and find someone thats not to pricey as you will only get a codes printed out to tell you what the ECU is saying then you would be best to tell us the codes on here

just one thing have a look or study topics about the EGR valve just in case thats the cause maybe give the fuel filter a change but fill it with diesel first out of a clean fuel can. you have to use a small pipe and a funnel to fill new filter pop the pipes back on but make a note were they go then if your lucky turn the engine over to see if it fires but dont keep turn it over if it dont start my tip is to park the car on a hill when doing the the change and it should start 1st time if not bump it in 2nd gear.

john
Z3 MON
Any reason why you need to prefill it and why you have starting issues changing the filter ??
frd2krd
Z3 MON THIS WAS 1DSPIKEY TELLING ME HIS PROBLEM AND SAYING WHAT TO DO.THANKS
1djspikey
[quote name='Z3 MON' timestamp='1328619705' post='165260']
Any reason why you need to prefill it and why you have starting issues changing the filter ??
[/quote]

The fuel pump will not drag the fuel from the tank and also theres no primming pump to draw fuel back in to the lines not sure if many folks have heard of parking there cars down hill when replacing filter but to be honest i think it stops the fuel running back to the tank i did this and was told about it and it worked for me ;)

john
Z3 MON
That's just stupid design lol. So how would Ford deal with this when they change it because surely they can't do them all on a hill??? Lol
1djspikey
[quote name='Z3 MON' timestamp='1328624562' post='165274']
That's just stupid design lol. So how would Ford deal with this when they change it because surely they can't do them all on a hill??? Lol
[/quote]

Ok you win :P
Samwell
Hi

I had EXACTLY the same problem a few days ago/still.

All was fine until I had 2 belts changed at a garage. Since then I couldnt get more than 30mpg. A few days after, car goes into limp mode and glow plug light flashing. It came to the point where the car wouldnt start at all and blew out a ton of white smoke in the process of trying.

I got a guy with the diagnostic equipment around who found 3 fault codes. 2 for pressure issue and 1 for an injector. He cleared the pressure codes and solved that issue, the injector had to be re-coded. He put in diesel additive and it now starts first time like it did before without the smoke. He thought that I might have used a poor diesel. This infact was true. I used a full tank of sainsburys finest budget diesel and never again!!! I didnt even tell him this but he thought it was that. Currently, have driven it about 30/50 miles and the lights stayed off. He's advised to take it easy and not put the pedal to the metal for a bit. So far so good but the car still sounds like its slightly struggling.

I might take it to an ex-ford dealer with the official equipment in the near future, sooner rather than later if the light comes on again. Id get it checked asap.

Wether its of any relation, I dont know, but my air filter to turbo hose came off in the process of it breaking down... cause or effect... who knows. Worth checking?
frd2krd
hi itook it for a diagnostic check and all that came up was the code for the injector so he cleared code and fingers crossed it will be alright for now also i did let my deisel run down to nearly zero so could have been something in tank many thanks for all your replies.frd
Z3 MON
good news :)

fingers crossed all is ok.


Full Colour Version: Glow Worm Light
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.