Help - Search - Members - Calendar
Full Version: 55 Reg 1.6 Tdci Sport Electrical Gremlins
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
aussiegit
hi guys just bought a 55 plate 1.6 tdci sport ... got a couple of problems with the instrument panel ...
1, the indicator lights do not flash when the indicators are on no click either ..the lights outside work perfectly as do the hazards ... any ideas?

2, the handbrake warning light stays on all the time , nothing wrong with the handbrake or the brakes ...

a couple of times they have worked and the warning light has gone off and the indicator lights work , but not for long ...
intermittant short maybe ... dont know where to start so please any assistance would be greatly appreciated guys

cheers

aussiegit
Preee
Sounds like a bad connection either on the cluster plug socket or inside the cluster , you may have to remove it and try replugging it back in.

failing that its more than likely a fault inside the cluster , i believe the solder inside is not great on the earlier models
aussiegit
hi great thanks for the info can you tell me where the cluster is ? apologies for my ignorance

cheers
aussiegit
Preee
Sorry , i was referring to the Instrument Cluster the Speedo unit
aussiegit
ok can i get to it from underneath the dash ?
cheers
aussiegit
Stoney871
You'll need to pull the cluster out of the dash.
I'm sure someone here has the proper process and will share it with you.


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.