Help - Search - Members - Calendar
Full Version: Rear Suspension Problems
Ford Owners Club - Ford Forums > Welcome to Ford Owners Club > General Ford Related Discussions
mathewmmr
Right ive had my car lowered on supersport springs and dampers and as some of you may know ive been having terrible problems as they were never fitted correctly in the first place. I went to look at my rear suspension today, took off the top cups and both circlips have been pushed up and now arnt doing anything. Also they have always stuck out the top of the chassis.

This is how much they stick out.
[IMG]http://i589.photobucket.com/albums/ss334/mathew0m2/IMG_1219.jpg[/IMG]

I think i can sort that by cutting and grinding that long bit down or off??
[IMG]http://i589.photobucket.com/albums/ss334/mathew0m2/IMG_1223.jpg[/IMG]

And these are the top circlips that have been pushed up (Im pretty sure your only meant to have one circlip on each, but theres 2?)
[IMG]http://i589.photobucket.com/albums/ss334/mathew0m2/IMG_1220.jpg[/IMG]
[IMG]http://i589.photobucket.com/albums/ss334/mathew0m2/IMG_1222.jpg[/IMG]

Any help would be much appreciated thanks!!
mathewmmr
Right i think i may have sorted the problem but just want to know for sure, so please tell me if anything doesnt look right!

So i took the strut assembly out, put the bottom in a vice and compressed the spring.
[img]http://i589.photobucket.com/albums/ss334/mathew0m2/IMG_1230.jpg[/img]

Then i put the bottom circlip on.
[img]http://i589.photobucket.com/albums/ss334/mathew0m2/IMG_1232.jpg[/img]

Then put the rubber top mount on and the top cirlcip.
[img]http://i589.photobucket.com/albums/ss334/mathew0m2/IMG_1233.jpg[/img]

The de-compressed the spring.
[img]http://i589.photobucket.com/albums/ss334/mathew0m2/IMG_1234.jpg[/img]

Put it back on and put the bottom bolt in.
[img]http://i589.photobucket.com/albums/ss334/mathew0m2/IMG_1235.jpg[/img]

I then cut the top cup down so it would actually sit on the chassis and no the top circlip.
[img]http://i589.photobucket.com/albums/ss334/mathew0m2/IMG_1237.jpg[/img]

Then put the top bolt on, gave it a drive round the block and it seemed fine :)
[img]http://i589.photobucket.com/albums/ss334/mathew0m2/IMG_1238.jpg[/img]

Gonna do the other side tomorrow and see if anything else happens.


Full Colour Version: Rear Suspension Problems
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.