Help - Search - Members - Calendar
Full Version: Fluid Leak
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
fintious maximus
Hi all,

noticed a small pool (5ch diameter) of fluid under the car this morning and dabbed a finger in it. Fluid is pinky watery stuff with no strong smell. Had a look under the engine and from the front of the car, the left hand side at the bottom is what I think is power steering pump (?) which has a belt on it and is the lowest pulley of the set on that side of the engine.

a. is that the power steering pump and

b. is that likely to be the leaky culprit?

Can't see where the leak is coming from but the pulley housing is wet underneath.

Thanks in advance
Stoney871
Sounds like hydraulic fluid to me, so probably power steering.
Look at your power steering reservoir under the bonnet, are the colours / texture the same?
You can't miss the reservoir, it has a symbol on top of it like a steering wheel.
fintious maximus
checked that last night and they do appear to be the same. PS reservoir is full though?
pragmatix
Waht colour is your coolant, I ask because mines a pinky colour, if it was hydralic fluid it would have an oily feel
Z3 MON
I recon its coolant aswell, could it be your water pump ???
fintious maximus
It is also similar to coolant but the level hasn't changed in there either. If it is water pump is it a big job?
Z3 MON
It might be just the hose going onto the pump has come losse or has da slight split, probably near or under the clip that holds the pipe on judging by the minimal leakage
fintious maximus
Got the day off tomorrow so ging to get jacked up (and axle stands) to see what I can find. Just as a pointer, where is the water pump? Not got a Haynes yet...
stef123
[quote name='fintious maximus' timestamp='1332266547' post='173661']
Got the day off tomorrow so ging to get jacked up (and axle stands) to see what I can find. Just as a pointer, where is the water pump? Not got a Haynes yet...
[/quote]

its driven off the auxiliary belt.
Z3 MON
Drivers side :)
fintious maximus
Havn't had chance to get under yet but have noticed that the last 5 days there has been no leak! Could it have been overfilled and water was expelling from expansion tank drain? All levels are perfect


Full Colour Version: Fluid Leak
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615