Help - Search - Members - Calendar
Full Version: 2.0 Tdci Hard To Start After Engine Change
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
STEADS
Right guys i need some help at a bit of a loss at the mo recently changed my 2.0 tdci engine (puegeot) finaly got the fuel through and eventually got it started sounds fine bit of a smell of diesel in the exhaust smoke but i,ve put this down to injectors need reprogramming (recently had them cleaned ) now this is where the prob starts turn engine off wont restart can crank it till the cows come home on the odd occasion will fire up sounds fine switch off cant restart . i,ve changed the throttle body off my old manifold as the one on this engine was naff floppy butterfly valve . so ruled that out the fuel seems to drain back out of the pump more noticable if you go to it next morning so i,m drawn towards the pump takes a bit of cranking to build up to 1800 psi which it seems to fire at .any help pointers appreciated i,ve still got the old pump on the other engine and will endevour to swop in the morning . but if any one has had smilar probs maybe you can help me .at the mo if i had any hair i,d pull it out.
STEADS
Update problem sorted changed fuel pumps stared virtualy straight away turn it off restarts no problem so the moral of this story is dont assume everthing is ok when you buy second hand . for all those of you out there who have the puegeot 2ltr engine fitted and it ever requires a pump changing dont be conned at the main stealer saying its a big job special tools got to be timed and programmed no it does not about half hour to change remove air box battery and tray disconect two sensors 3 fuel lines (cant get any of it wrong on refitting as they will only go where they came from ) 3 13mm bolts tap with a rubber mallet and its off watch out for the drive dog coming out with it just slot that back in place on refitment just make sure your alighn drive on pump so that it slots into drive dog simples .bolt all back up a few cranks to build up pressure hey presto .and after seeing the affects of how the old pump performed i,d like to bet this is a cause of a lot of unresolved starting problems ran fine when i could start it just very difficult to restart after switching off fuel seemed to drain back out of pump might be worth a look if any one else has such issues as its clear to see there is no fuel present on entry into pump hope this helps others in future .


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.