Help - Search - Members - Calendar
Full Version: Ford KA Revving Problems
Ford Owners Club - Ford Forums > Ford Models > Ford KA / StreetKA Club
dab1009dab
I have a 2006 Ford KA (1.3).

About 9 months ago it started to rev itself when the engine was idling (i.e. it sounds like it is a boy racer waiting to pull away at the traffic lights) - and idling at quite a high rate (i.e. it can drive itself along at about 15-20 miles per hour in 2nd gear without my foot even being on the accelerator). Initially it only did this intermittently - but it is now more or less a permanent problem, and makes the car quite unnerving to drive.

I have taken to our local garage, who have replaced the idle control valve; throttle position sensor; and MAP sensor. They have also stripped down the throttle mechanism and put it all back together again. Each time its been in the garage, it drives OK for about 10-15 miles, before starting to play up again.

So far, I've spent about 250 trying to solve the problem - all of which has been wasted.

I now have a car which is not yet 3 years old - only has 20k miles on the clock - but which I don't like to drive and won't be able to sell because of this seemingly unsolveable problem.

Has anybody else had a similar problem, and if so were they able to solve it ?
hendrix
IF the cars not yet three yrs old it still has ford warranty running take to ford dealer this is a warranty issue.
hoppaz
[quote name='dab1009dab' post='10956' date='Feb 1 2009, 11:39 AM']I have a 2006 Ford KA (1.3).

About 9 months ago it started to rev itself when the engine was idling (i.e. it sounds like it is a boy racer waiting to pull away at the traffic lights) - and idling at quite a high rate (i.e. it can drive itself along at about 15-20 miles per hour in 2nd gear without my foot even being on the accelerator). Initially it only did this intermittently - but it is now more or less a permanent problem, and makes the car quite unnerving to drive.

I have taken to our local garage, who have replaced the idle control valve; throttle position sensor; and MAP sensor. They have also stripped down the throttle mechanism and put it all back together again. Each time its been in the garage, it drives OK for about 10-15 miles, before starting to play up again.

So far, I've spent about 250 trying to solve the problem - all of which has been wasted.

I now have a car which is not yet 3 years old - only has 20k miles on the clock - but which I don't like to drive and won't be able to sell because of this seemingly unsolveable problem.

Has anybody else had a similar problem, and if so were they able to solve it ?[/quote]

I am not too familiar with Ka's but I have just posted a new thread on behalf of my gf's Ford ka. Sounds to me like the throttle is at fault. My rover had the same issue which was solved by buying a new aluminium throttle body (not sure what the throttle arrangement is on a KA). The high revs seems to me because air is getting into the engine. Could be that the throttle butterfly is sticking slightly open due to warpage. The garage has changed all of the other components that could be the cause. Hope this helps.
dab1009dab
[quote name='hendrix' post='11004' date='Feb 1 2009, 06:55 PM']IF the cars not yet three yrs old it still has ford warranty running take to ford dealer this is a warranty issue.[/quote]


The car's warranty document says it only has cover for 1 year - but after reading your response we phoned the Ford dealership where we bought the car, who said that it was in fact a 3 year warranty - and they have agreed to look at it under warranty. We wouldn't of thought of doing this without your response - so thank you !
hendrix
No problem at all.


Full Colour Version: Ford KA Revving Problems
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.