Help - Search - Members - Calendar
Full Version: No power going uphill
Ford Owners Club - Ford Forums > Ford Models > Ford KA / StreetKA Club
bfc1980
Hi all.

Driving back from Lancs to Leeds this evening I had major problems mainting speed up the hills on the M62. Going uphill I had absolutely no power even with the foot down and my speed struggled to get above 30mph. I've recently had a new clutch fitted (all 3 parts 2 weeks ago) so I'm sure this can't be the reason. In the morning I noticed fur coming out of the back of the exhaust pipe (at first it looked like a rat might have climbed in there). The old man says that there's probably a hole in the silencer and this is the fur coming out of it. Do you think the power problem and fur are related? Thanks very much for the help.
delboy
if it is the back box failing that would cause the lack of power.
there is silencer material in side them so it may well be that has blocked your exhaust
it's like haveing the old potato shoved in the thing m8.

get a new box fitted or atleast get it checked out.
i have never heard or the material cumming out tof them as i thaught it was
just a chamber with holes in but i maybe wrong
bfc1980
[quote name='delboy' post='11045' date='Feb 2 2009, 06:49 AM']if it is the back box failing that would cause the lack of power.
there is silencer material in side them so it may well be that has blocked your exhaust
it's like haveing the old potato shoved in the thing m8.

get a new box fitted or atleast get it checked out.
i have never heard or the material cumming out tof them as i thaught it was
just a chamber with holes in but i maybe wrong[/quote]

Thanks delboy. Thats what i thought the prob might be. Found out though that on these KA's the exhaust is all one unit so will have to buy whole system. How much do you think it could cost?
delboy
you will be looking at around 85.oo
that's what i paid for my son's.
he's got the 1300 engine 1998 model
& i think they are the same
bfc1980
[quote name='delboy' post='11103' date='Feb 2 2009, 04:46 PM']you will be looking at around 85.oo
that's what i paid for my son's.
he's got the 1300 engine 1998 model
& i think they are the same[/quote]


Cheers delboy.

85 sounds quite reasonable. Did that include labour costs?
delboy
all in inc vat & fitting.


Full Colour Version: No power going uphill
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615