Help - Search - Members - Calendar
Full Version: Escort stalling
Ford Owners Club - Ford Forums > Ford Models > Ford Escort Club
Alex
Right here we go,

i have searched through the previous threads but with nothing concrete to help me, so here goes, any help is much appreciated.

My escort GTI Estate is behaving very oddly, on first start (cold) the engine runs normally at about 950rpm, this is all fine, i set of driving and at the first junction, roundabout etc i depress the clutch, the revs drop to 500rpm and one of two things happen
1) it stays above 500 rpm, the battery light flickers momentarily, and the car begings to adjusts its revs between 500rpm and 1100 rpm.
2) It drops below 500rpm, and stalls

This doesnt just happen as the engine is getting up to speed, it can happen at any time during my hour long journey to work, and has been known to happen as i slow to a give way point and not actually stop!

I have heard this could be the ISV but i dont know where it is so i am having problems finding it to clean/replace it!

Help me please!

Alex
scorty_fun?
[quote name='Alex' post='11352' date='Feb 5 2009, 01:51 PM']Right here we go,

i have searched through the previous threads but with nothing concrete to help me, so here goes, any help is much appreciated.

My escort GTI Estate is behaving very oddly, on first start (cold) the engine runs normally at about 950rpm, this is all fine, i set of driving and at the first junction, roundabout etc i depress the clutch, the revs drop to 500rpm and one of two things happen
1) it stays above 500 rpm, the battery light flickers momentarily, and the car begings to adjusts its revs between 500rpm and 1100 rpm.
2) It drops below 500rpm, and stalls

This doesnt just happen as the engine is getting up to speed, it can happen at any time during my hour long journey to work, and has been known to happen as i slow to a give way point and not actually stop!

I have heard this could be the ISV but i dont know where it is so i am having problems finding it to clean/replace it!

Help me please!

Alex[/quote]

just after the air filter youve got the meter it has been known for the resistors to burn out this then means it doesnt tick over properly and when you come to a stop the car somtime stalls. hope this helps sam.
mintalkin
the icv would be the first suspect or a vacume leak this might help
[url="http://www.escortevolution.co.uk/howto/view.php?id=7"]http://www.escortevolution.co.uk/howto/view.php?id=7[/url]
decks
yeah mate its the idel controll valve or it could be the wee air pipe going in the the carb as thats what happened my one
vinnyvangough
Def ICV. Mine does the same, just aint got round to doing mine yet


Full Colour Version: Escort stalling
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.