Help - Search - Members - Calendar
Full Version: My Lovely Mondeo Is Humming(57 Plate Tdci)
Ford Owners Club - Ford Forums > Welcome to Ford Owners Club > General Ford Related Discussions
Raptor
Gents, please help. I was driving back from town today and my lovely quite running Mondeo started to hum from the rear... Its sounds like bearings to me. The car has done 60.000 miles. It is so quite as a rule. I have checked for play in the rear wheels and any grinding noises. All OK, could it still be bearings if none of these signs are evident? If I have to change them do you buy them as a complete hub assembly or just the bearings... I have had no trouble from this car in the two years i have had it. I did change the rear pads about 2 weeks ago and I did have to hit the rear calipers to try and free them a little. But like I said it has run perfect....

I hope someone can help???
pragmatix
Could be something to do with the rear brakes are they binding a bit, allways worth checking on the last job you did when a new fault in the same area happens
Raptor
I know what your saying. They are as free as a bird. No probs there. I know all the moves with this car, and if they were sticking a little bit i would know.
mintalkin
change the complete hub, if you can do the brakes you can swop the hub.

http://www.ebay.co.uk/itm/MONDEO-MK4-BRAND-NEW-REAR-WHEEL-BEARING-HUB-X1-2007-ON-/300516951475


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615