Help - Search - Members - Calendar
Full Version: O2 Sensor Broken?
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
suddste
Hello,

I've been trying to find whats causing my lack of power issue for a while now., I was told to look at the o2 sensor readings but I dont know whats right and whats wrong. I think I may have found that one of the o2 sensors is hardly reading at all but I dont know if my focus has two o2 sensors or not. I have supplied a pic of readings connected to my OBD port. If it turns out my car has two sensors, then I beleive the 2nd (straight line reading) is wrong?

Could it be this sensor thats causing my lack of powerr, and if it is, is it easy/cheap to change?
dezwez
hi if yours is a 1998 to 2005 it should have two one before the cat and one after the cat need two have a good look
i dont no about the later petrol ones
suddste
[quote name='dezwez' timestamp='1338647295' post='185188']
hi if yours is a 1998 to 2005 it should have two one before the cat and one after the cat need two have a good look
i dont no about the later petrol ones
[/quote]

thats correct, mine is a 2004 mk1.5
david295
Mine is a 1998 to 2005 and only has 1 before cat, the other hole is blocked off, and no wiring for it
dezwez
then theres are two look over the back of the engine bay you will see the frist one there it in the down pipe the second one is under the car
just after the cat hope this helps
suddste
[quote name='dezwez' timestamp='1338648931' post='185198']
then theres are two look over the back of the engine bay you will see the frist one there it in the down pipe the second one is under the car
just after the cat hope this helps
[/quote]

thanks, but do you know if the pic looks right for o2 sensors? I thought they should be both alternating like the one on the left
dezwez
someone should be along that can tell you that just post the picture
again your better waiting till the evening more members on line
suddste
[quote name='dezwez' timestamp='1338651438' post='185205']
someone should be along that can tell you that just post the picture
again your better waiting till the evening more members on line
[/quote]

thanks


Full Colour Version: O2 Sensor Broken?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615