Help - Search - Members - Calendar
Full Version: Mk2 Mondeo 2.0 Auto Petrol Engine Problem
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
rds60h
Hi,
I have a Mk2 Mondeo 2.0 Auto (Petrol engine) when I went to start it this morning it made a strange sound but started, I slowly revved up to see if anything else would happen. When I got to 4000 Revs the engine started to shake quite violently and it sounded as if it was misfiring.
Has anyboby any ideas what it could be and possible fixes please.
Last September I had a misfire but at all revs, then I changed the plugs, leads and coil pack and everything was fine. But as I have said this was a constant misfire, this new problem seems to be at 4000 revs and above although I haven't driven away yet in case it is something more serious.
Thanks in advance.
Stoney871
Possibly a dodgy cam position sensor?
rds60h
[quote name='Stoney871' timestamp='1341234258' post='190400']
Possibly a dodgy cam position sensor?
[/quote]

Is it possible to check this before buying a new one ?
rds60h
Up-Date.
My wife drove the car to town and back this morning with no issues whilst driving.
On her return I tried gently revving the engine up to 4000 revs, at that point the engine began to "pop" and misfire but only slightly compared to previously.
I am sure I have read somewhere that this could be caused by the engine oil ?
If anyone can enlighten me and suggest a course of action please.


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.