Help - Search - Members - Calendar
Full Version: Heater And Stereo Not Working!
Ford Owners Club - Ford Forums > General Forums > Audio & Electronics
zippy77777
Hi guys this is driving me mad!

The blower in my car is for some reason only blowing cold air now, but the feeder pipes behind the dash in the bonnet are hot!
I've taken the facia off and all three dials are working as they should so where could the problem be? A fuse maybe, but which one or a relay?

Plus i took a perfectly good stereo out which was working fine and put in a new one and that one didn't work. On putting the old one back in that don't work either now, good day all round lol. Again is it a fuse and if so which one or maybe a relay?

Please help me if you can. My car is a 1999 Ford Fiesta 1.25 Zetec, T reg.......

Hope someone can shed some light, I'm going very grey here!!!
zippy77777
fixed stereo, it was a fuse, didn't know about the second fuse box by the steering wheel lol.

Any ideas on the heater? pleeeeeaseeeeeeeeee/??
oilburner79
Sounds like the Heater Control Valve really common fault on Fiestas,Pumas and Kas it's located just behind the bulkhead. Use a genuine Ford one as cheap ones last about a week!
zippy77777
nice one i can get a genuine one on ebay for £13. I'll get one :-)


Full Colour Version: Heater And Stereo Not Working!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615