Help - Search - Members - Calendar
Full Version: blowers blowing hot when set to cold
Ford Owners Club - Ford Forums > Ford Models > Ford Puma Club
shelly
HI COULD SOMEONE PLEASE HELP ME I HAVE JUST BOUGHT A PUMA 1.7I BUT WHEN I TURN THE BLOWERS TO COLD THEY STILL BLOW HOT THE CAR DOESNT OVER HEAT AND HAS WATER IN THE COOLING SYSTEM IT EVEN DOES IT WITH THE A/C TURNED ON IVE CHECKED ALL FUSES PLEASE HELP :(
mintalkin
sounds like the heater valve is stuck, common ford problem
shelly
[quote name='mintalkin' post='12043' date='Feb 14 2009, 12:08 AM']sounds like the heater valve is stuck, common ford problem[/quote]
hi many thanks for that youre 100 percent correct thank you
shelly
[quote name='mintalkin' post='12043' date='Feb 14 2009, 12:08 AM']sounds like the heater valve is stuck, common ford problem[/quote]
hi ive just found out you just saved me 45 pounds thank you it all helps
millard
Hi all

Just working on my mum's car and it has exactly this problem. Where is this heater valve and how can I fix it?

Thanks
Michael
mintalkin
the valve looks like this
[url="http://www.pumaspeed.co.uk/showdetails.php?id=499"]http://www.pumaspeed.co.uk/showdetails.php?id=499[/url]
and is accessed from the engine bay just follow the heater pipes on the cooling system. replacement is the sensible option


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.