Help - Search - Members - Calendar
Full Version: Ford Fiesta Mk7 Headunit - Ipod Track Navigation Not Working
Ford Owners Club - Ford Forums > General Forums > Audio & Electronics
Frank89
Hi all, long time reader first time poster. Recently bought myself a Ford Fiesta MK7 edge and it's fantastic in each and every way :-)

There is one minor gripe though which I'm hoping you guys may be able to help me out with........

When I plug my iPod into the headunit using the USB cable, I can listen to music from it with no problem and can scroll from track-to-track, but cannot navigate between albums/tracks/artists etc using the built in menu. Instead of being presented with a selection of 'Artist', 'Album', 'Genre' etc. - all I see is 'Track 0'. There are no other options.

Unfortunately, this means I need to unplug my ipod and select the album of my choice before I start driving or use the AUX cable instead (which doesn't charge it up when driving).

This ipod menu navigation did used to work but just stopped one day for some reason; is this a common problem which can easily be fixed as I've never heard about it before. I've also tried another ipod with it, but am experiencing the same problem. Given this, the fault is with the headunit. (FYI It's the built in one but without handsfree bluetooth capability.)

I'll probably take it into my nearest service center soon for them to have a look at it (as it's still under warranty) but is there anything else I could try before I do this? Many thanks.
tomtom70
Does your car have Bluetooth or not? (The USB/Ipod connection is different).
Frank89
[quote name='tomtom70' timestamp='1344161257' post='198941']
Does your car have Bluetooth or not? (The USB/Ipod connection is different).
[/quote]

hi tomtom, no I haven't got bluetooth - its just a USB connection.
DanGull
You need both the 3.5mm cable and the USB plugged into together for all the functionality to work. There are special Y-cables out there, but I preferred to use two separate long cables and then velcro the iPod to the underside of the seat for security.
Frank89
hi dangull, i have tried plugging my Aux cable & ipod lead together at once but unfortunately still had the same problem. cheers for your response though.

any other ideas?
DanGull
Which model of iPod? A non-dock connector model perhaps?
Frank89
its a 5th gen 60gb ipod which uses a dock connector to USB
Rob Millar
Hi, I am having the same problem, however instead of getting 'track 0' as you, mine says 'please wait' then simply returns back to the track name it was currently playing. I spoke to someone of the technical help team at ford and all they could recommend was just trying to update the software, but as my fiesta was build in jan 2012 it does not need it and wont recognise the update files.

Looking desperately for a fix!
Rhi1984
Hello!

I have a fiesta edge 2012 with the same problem, I took it to ford and they checked the software but it was up to date. They then told me that I needed to purchase the USB y cable with a jack for 28. I told them that the USB has always worked and I have never needed the jack. They kept telling me that it wouldn't have worked, but it definitely did! I have resigned myself to the fact that it must be because my phone updated onto iOS 6. It worked fine before then. Hoping apple will sort something out, but it's very annoying!
saysha

I can help to resolved the problem for a while pull out the fuse that give a power to audio system then put it back for reset audio system
That fuse can find behind the glove compartment. Sorry about my english

Velar

I realise this is an old post, but the posts here really helped me, particularly saysha (thanks!).  I had the same "Track 0" issue as the OP which was really frustrating in my 2011 Fiesta Edge (no bluetooth, just USB and Aux).  To solve it, as saysha suggested, I dropped down the glovebox using the instructions in the manual to get to the passenger compartment fuse box.  I checked that everything was turned off and that the ignition key wasn't in, again as the manual describes.  I then pulled out the fuse for "Audio System, Bluetooth" (fuse 21 in my Fiesta), kept it out for 30 seconds and reinserted it.  I turned on the stereo, plugged in the ipod and the problem was solved.  Thanks to all the posters above.



This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.