Help - Search - Members - Calendar
Full Version: Gearbox Oil Low/losing Power On 2.0 Auto Mk3
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
SnowyUK
Hi all - Just wondered if anyone has any ideas :

Car is 2001 x-reg Mk3 2.0 Petrol Auto Zetec Mondeo with 69k.

Only problem I know of is ticking tumble flaps (removing them next week).

I have noticed another issue twice now :

99% of the time the car behaves as it should.

Very occasionally (it's happened twice) I seem to lose power. I will be tootling along at, say, 30 and need to accelerate. I boot down and, whilst it does accelerate, it doesn't seem to do it with the same "sharpness" that t does most of the time. Basically, there seems to be a LOT of revs for not much acceleration.

I would say that if it were a manual I would be in the wrong gear (say 4th instead of 3rd) or the clutch was slipping slightly.

Also, when the "power loss" happens, kickdown seems to work, but not as well as it should (as if it changed from 3rd to 2nd instead of 3rd to 1st if you get my drift).

Then the problem goes away and all is well again.

I thought it may be the auto box slipping and have dipped my gearbox oil (hot engine, running in park on level surface) and here are my findings :

I've dipped it and the oil seems red (a bit brownish but not "engine oil brown") - It smells, basically, of oil lol!

HOWEVER... The oil is BELOW the start of the hatched area on the dipstick.

I am guessing the previous owner had a problem with this as in the boot I have found an almost full bottle of "Carlube ATF-Q3" auto transmission fluid. The spec is Ford Mercon WSPM2C185A

I have topped her up (through the dipstick hole), run her round the block and then dipped again. I think I may have put too much in now! (or maybe she isn't hot enough or I haven't left it long enough after filling).

I have attached a piccie I drew of the dipstick. The end that say "tip" is the gearbox end. The dark arrow on the left is the level it was at BEFORE I filled up - The red arrow on the right is the level it is NOW at.

The hatched area and the "do not fill this area" writing are etched onto the dipstick.

Any help would be MUCH appreciated! :)
ppeter7
is there signs of it leaking and maybe a oil change might help
Podzak
What's a "tumble flap"? :mellow:
ppeter7
[quote name='Podzak' timestamp='1346451071' post='204355']
What's a "tumble flap"? :mellow:
[/quote] its the flaps on the inlet manifold lets in more air when u throttle down like on a old carb engine


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.