Help - Search - Members - Calendar
Full Version: Need Advice
Ford Owners Club - Ford Forums > Welcome to Ford Owners Club > General Chat
Jason 'Tweek' Batty
Well I bought a beat 675 from a forum member a few weeks back. after having problems getting the power on, finding out it had a break on a power board, and fixing it. Then to discover there was no sound coming from the head unit. After taking it to an audio specialist in Manchester he checked the unit out and said the soundchip was more than likely blown and it would not be worth fixing.

I had a dispute open in paypal but because I had the unit repaired, to hopefully get the power back on and not have to send it back and get a refund etc, they closed it and told me I could not claim because it had been repaired????

So I have contacted the forum member numerous times via PM and told him the situation. I want to send the unit back and get a refund but I have had no reply. I am out of pocket £80 for the unit plus £30 for an auto electrician to test the unit and my car.

I needs advice on what to do next if anyone can help please.
DanGull
Jason - contact me by PM with more information including the other member involved and I'll see what I can do to help.


Full Colour Version: Need Advice
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615