Help - Search - Members - Calendar
Full Version: Abs ..esp Light Staying On
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
busajohn
Hi everyone i have a 57 plate 2 ltr tdci ghia mondeo and for the last 3 days my abs..esp light has stayed on my dash..cleaned both abs sensors on front but the lights are still on Anyone help ,e plz TIa ,,,John
busajohn
any help before i have to pay £120 for it to go on a machine ...thanks
Stoney871
You'll probably find you need to clear the fault codes from the system.
Anyone with an OBDII reader can do it.
ppeter7
how about rear ones have you checked wires arnt broke
busajohn
[url="http://www.fordownersclub.com/forums/user/32731-ppeter7/"][color="#545454"]ppeter7[/color][/url]...yes mate we done the back ones aswell
busajohn
[quote name='Stoney871' timestamp='1348861080' post='208808']
You'll probably find you need to clear the fault codes from the system.
Anyone with an OBDII reader can do it.
[/quote]
thanls for your reply//a mate put a fault code reader on...John it...was a handheld one but no code come up..he said it didnt read abs faults
Stoney871
Any garage with a professional reader will be able to look deeper for codes.
A lot of the time even when a fault is fixed the code stays resident on the system until read and cleared so warning lights and fault warnings will still show.
busajohn
[quote name='Stoney871' timestamp='1348862875' post='208812']
Any garage with a professional reader will be able to look deeper for codes.
A lot of the time even when a fault is fixed the code stays resident on the system until read and cleared so warning lights and fault warnings will still show.
[/quote]
ok thanks
busajohn
i dont know if this makes any difference to my problem..but last night i noticed my antilock brakes are not working and the button for the traction control(esp)on dash wont go on or off...thanks
stef123
Your abs will not work as there is a fault.

Have you checked the connections at the sensors and under the car?
busajohn
[quote name='stef123' timestamp='1348918123' post='208869']
Your abs will not work as there is a fault.

Have you checked the connections at the sensors and under the car?
[/quote]
thanks for your reply..i dont know anything about car bits...but a mate at the bottom of the road has took all the sensor plugs of and cleaned them front and raer ..thats all i know...John
busajohn
Just want to say thanks to you all for your help..My drivers side front sensor has gone so ordered one from ford £29 bit of confusion if this will sort out the esp aswell as abs aswell ...John
stef123
[quote name='busajohn' timestamp='1349111749' post='209223']
Just want to say thanks to you all for your help..My drivers side front sensor has gone so ordered one from ford £29 bit of confusion if this will sort out the esp aswell as abs aswell ...John
[/quote]

The ESP takes it reading from the abs system so the chances are it will sort that out too
busajohn
[quote name='stef123' timestamp='1349111835' post='209224']
The ESP takes it reading from the abs system so the chances are it will sort that out too
[/quote]
ok thanks for that
busajohn
Hi again ..can someone help ..i went to my local ford dealer and told them i wanted a abs/esp sensor front drivers side he told me £29 so i ordered it /went to pick up this morning and the (tw*t ) ordred me a wiring loom for the sensor ..then he said i will order the sensor now its a whoping £91 anyone know a part number... thanks
busajohn
hello again..right i got my sensor and fitted it but the light on my dash are still on ..will i have to have them cleared with a fault reader or should they have gone off when new sensor was fitted,,,thanks ,jOHN
busajohn
anyone recomend a fault reader that does abs/esp plz...John
busajohn
update for you all.. fitted the new sensor ..when ignition is switched on the abs/esp go out after say 5 seconds but as soon as you drive off they come back on...look like a ford jobby ,,,John
stef123
Have you checked the and ring on the shaft?
busajohn
[quote name='stef123' timestamp='1350040894' post='210989']
Have you checked the and ring on the shaft?
[/quote]i dont know anything about cars..i have to relay messages to a mate ..what ring n shaft thanks
stef123
[quote name='busajohn' timestamp='1350072063' post='211065']
i dont know anything about cars..i have to relay messages to a mate ..what ring n shaft thanks
[/quote]

im not sure what your car has but the abs sensor will pick its signal from a ring which is fitted to the end of the driveshaft or sometimes from the wheel bearing itself. if whatever one of these your car has is damaged the ecu will throw an error up for that wheel.
busajohn
[quote name='stef123' timestamp='1350123371' post='211127']
im not sure what your car has but the abs sensor will pick its signal from a ring which is fitted to the end of the driveshaft or sometimes from the wheel bearing itself. if whatever one of these your car has is damaged the ecu will throw an error up for that wheel.
[/quote]
m4 2l tdci ghia


Full Colour Version: Abs ..esp Light Staying On
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615