Help - Search - Members - Calendar
Full Version: 59Plate Focus Dash Problems
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
talksy
Hi, just wondering if this is the norm... I have noticed now the weather has started getting cold that the LCD display on my focus dash has become extreemly slow and laggy on cold mornings.

See attached video.

Would like to hear from other owners to see if this could potentially be a problem with my dash or just cold weather. It seems to improve as the day goes on, and like I say, has only been happening since the weather has got cold.

My video is viewable on youtube also: [url="http://www.youtube.com/watch?v=PJxOivjfKsg&safe=active"]http://www.youtube.com/watch?v=PJxOivjfKsg&safe=active[/url]
gumpy321
I'm sorry to de-rail this thread, but can anyone answer the following question:

I want the display like above to show degrees celcius and miles. However, If I set the display to miles, Fahrenheit is shown instead. So I either have to pick imperial or Metric? Is there any way around this?
gumpy321
And to answer the original question, yes, mine does that. Only when it's really cold though, like -4 and under.
artscot79
its a liquid crystal display and yes mine does it too when its very cold
Steven33
[quote name='gumpy321' timestamp='1349887065' post='210654']
I'm sorry to de-rail this thread, but can anyone answer the following question:

I want the display like above to show degrees celcius and miles. However, If I set the display to miles, Fahrenheit is shown instead. So I either have to pick imperial or Metric? Is there any way around this?
[/quote]

Off the top of my head I cant quite remember how I changed it so I had temp in celcius but everything else in imperial (miles, mph etc). But try scrolling through the displays until temp is displayed then hold down the reset button. It is something like that, let us know if that works...
gumpy321
[quote name='Steven33' timestamp='1349969181' post='210822']
Off the top of my head I cant quite remember how I changed it so I had temp in celcius but everything else in imperial (miles, mph etc). But try scrolling through the displays until temp is displayed then hold down the reset button. It is something like that, let us know if that works...
[/quote]

Yeah, I found out on google. You've got to scroll through to where the image of a thermometer is, and the press ok for two seconds. It then changes to Celsius.

Thanks
RB2004
its also due to the smart charging system, as far as I know.. on cold mornings you have a PTC heater that activates on diesel models, glow plug heaters, front and rear window heaters etc fan speed higher, headlamps? so it uses a lot of voltage which takes some away from the instrument cluster.

maybe mine has a fault but also I sometimes find the display is a bit fuzzy on some menus until I press the button on the end of the stalk then it corrects itself.

others have noted that when driving along they notice the big red screen brighten every time they put their foot on the accelerator.

Also worth getting the latest firmware version installed on your instrument cluster... I upgraded mine and found it fixed a few bugs, like how it was giving me false fuel computer information.. lol would say I had 7 miles less then suddenly say I had another 30 miles.. doesnt do that now.
talksy
Thanks for your posts. I have not noticed it being to do with having more electrical things on. It seems to be doing it from any temps 12 degrees c and below.
The other weekend, it was a sunny saturday around 1130am. Not freezing cold, the dash was saying 12oc and it was doing it then. I didn't have lights, heaters, fans, heated screens nothing just the radio on.

Might need to take it into Ford for a warranty job if it continues. One some mornings, it is hardly readable.


Full Colour Version: 59Plate Focus Dash Problems
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.