Help - Search - Members - Calendar
Full Version: Hi
Ford Owners Club - Ford Forums > Welcome to Ford Owners Club > New Member Introductions
merchantofdoom
Hi all. Having recently purchased a cheap fiesta as a work hack I've noticed a few problems. When trying to wash the windscreen the water barely reaches the screen and the rear doesn't work at all. I can hear the motor when pulling the stalk on so don't think it's this. Is this a common fault and can anyone help with how to check if that's the fault?

Thanks in advance.
Lenny
[quote name='merchantofdoom' timestamp='1350552790' post='212231']
Hi all. Having recently purchased a cheap fiesta as a work hack I've noticed a few problems. When trying to wash the windscreen the water barely reaches the screen and the rear doesn't work at all. I can hear the motor when pulling the stalk on so don't think it's this. Is this a common fault and can anyone help with how to check if that's the fault?

Thanks in advance.
[/quote]
Welcome to the forum,
Try putting high flow of water in the bottle like the garden hose for ten minutes to flush out contaminants and some viniger to break down lime.
Then unplug the pipes front the rear of the jets, and press the washer.
If you get good flow then you need new jets.
But if flow is bad then the seal in the pump is passing resulting in low pressure.


Full Colour Version: Hi
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615