Help - Search - Members - Calendar
Full Version: Interior Light
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
Big_dom91
Hello guys new to this and this is my first post which is probaly the easiest fix but thats why were on this site haha

Anyways iv got a mk2.5 59 3DR focus and the interior light in the cieling panel was playing up earlier and wouldnt turn on when the doors were all closed and now after taking the lens off and looking to see if anything was wrong i.e bulbs need replacing there is only one bulb and since i put the lens back on the light constantly stays on whilst the doors are closed when the switch is in the button down postion as ifi want them on and when its in like the neutral position so the light comes on when the doors are open so little bit confused ???
DaveRushton
Maybe you have knocked something out? Take it back down and re-seat it!
Big_dom91
Ill try that in morning but already took it down after i noticed it but it was going dark

Cheers
Haz93
Hi mate, welcome to the forum :)

If you are still having this problem tomorrow when you have had chance to look, you could upload a photo of which interior light unit you have. Do you mean the front one or the one above the rear seats?? (not sure if your 3 door will have the rear one but that's the only one on my car with just one bulb in it.

I may be a bit more use then :P
Big_dom91
@haz93

Its the front one right above the gear stick but i originally thort it may be the bulb/bulbs but like a say when iv took the lens off its only got the one bulb :S
Haz93
Sounds a bit strange, mine looks like this:



Maybe its been fitted by a previous owner to produce more light from a single bulb :S Not sure though. I can't understand why it would play up though. so you saying when its in "door open" mode it stays on constantly? even after the car is locked?
Big_dom91
No when the doors are closed but the button is not pressed on either side so wen the doors are closed the light should be off but when doors are open it should go on but when the doors are closed the light is on even tho it isnt pressed in to be on if that makes any sense itll probs be easier if i was to take a pic in mornin showin the switch and the light.
Stoney871
Sounds like you got the wires crossed somehow.
DaveRushton
Light only dims when you lock it doesnt it?
Stoney871
The light should always fade out when it switches off.
Big_dom91
Lightbonly goes off when i put the switch in off so it never comes on :S
Haz93
The light should go off when locking, also after about 2 mins after ignition off if the car is not locked. it does sound like you have the wiring the wrong way round, although this would be hard as the two connectors are different shapes.

You could take the light unit out to check the wiring, only need a flat screwdriver and a few seconds. see my guide to help remove the light unit.

[url="http://www.fordownersclub.com/forums/tutorials/article/34-guide-to-fitting-ambient-submarine-lighting-focus-fiesta-mondeo/"]http://www.fordownersclub.com/forums/tutorials/article/34-guide-to-fitting-ambient-submarine-lighting-focus-fiesta-mondeo/[/url]

There should be two different connectors, one will have two wires and the other has just one. make sure these are attached firmly and there is no damage to the wiring
Big_dom91
This is what it was like this morning after the doors had been closed for a few minutes


Big_dom91
Look like an idiot now aswell iv took photos of the problem but dont no how to upload them on this thread any help plz im using a mobile aswell ?
Haz93
I don't think you can upload via a mobile. Best way is on a pc through the 'more reply options' section. You can try using the 'use full version' button at the bottom if you do t have access to a pc
Big_dom91
Cheers heres some of the photos iv took showing what the problem is much appreciated for any help thanks.
Stoney871
Wires appear connected properly.
Explain again what the light does in these positions-
When switch to the left?
When switch in the middle?
When switch to the right?
Big_dom91
When switched to the left its off completley when in the middle it stays on completley and the same for switched to the right but it should fade out wen its in the middle when the doors close ??
Haz93
It only fades out when the car is locked not when the doors are closed. try sitting inside with no key in the car. make sure your light is set in the middle and use the door lock. if it goes out then its working correctly. If not there may be a section of that copper circuit on the back of the unit that is in contact between the two different circuits.

Also got to say that defo the first focus I've seen with a single bulb unit in the front. If your problem continues, you may want to change the unit for a 3 bulb type

[url="http://www.ebay.co.uk/itm/Ford-Focus-mk4-2010-Interior-Light-/251160394352?pt=UK_CarsParts_Vehicles_CarParts_SM&hash=item3a7a537a70"]http://www.ebay.co.uk/itm/Ford-Focus-mk4-2010-Interior-Light-/251160394352?pt=UK_CarsParts_Vehicles_CarParts_SM&hash=item3a7a537a70[/url]

Thats the unit used in the facelift focus, seems a bit steep though. best to shop around if you do want to replace it. the same unit will fit from a fiesta mk6/7 or mondeo mk3/4 cmax etc...
Stoney871
I would say that maybe the switch is damaged.
ShinyAndy
I have exactly the same problem with my interior lights too, still no idea why!
STEADS
i would be looking at the switch on the door not the light unit just not 100% sure if they still use the old style plunger swith to turn the light out or is now in corporated into the door lock only sayin as in the past when curtesy lghts have played up its been the switch on the door not the unit its self worth havin a delve .
ShinyAndy
I can see no switch on the doors - at least not on mine anyway!
Big_dom91
Its a nucence really coz it just has to be permantly off might go to fords and see what they say coz they serviced it last week and replaced a fuse so maybe theyve nocked something in the fuse box but thanks for ur inputs people and ill post the results.
Big_dom91
Right everybody found the culprit it was after i compared the light switch to the one on my dads focus that i realised the triangular copper fittments attached to the switch were too far apart on my switch so after a little squeeze together everything is back to normal :) once again thanks for everyones help
k13r4n
[quote name='Big_dom91' timestamp='1351071689' post='213317']
Look like an idiot now aswell iv took photos of the problem but dont no how to upload them on this thread any help plz im using a mobile aswell ?
[/quote]

Off topic a bit but I use my HTC one x and can upload photos all I do is click on

More reply options (beside post icon) a new page should load
Click on try our basic uploader
Choose file then my phone comes up with what I want to up upload ie music pictures etc
I then open my photos go to appropriate album then when I click on my photo it takes me back to the upload page
I then click attach this file
Wait a few mins
Then make a comment to go with picture then click add reply

Hope this helps you and everyone who didn't know and I would recommend using a smart phone to do this btw ie above HTC iPhone (spit) etc


Full Colour Version: Interior Light
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.