ok i don't mean to brag but i think i may be the unluckiest ford owner you will ever meet.

had the 1.6 focus tdci not even a year,

No.1. firstly the speedometer kept sticking, useually about 10 mph over the actual mph, so i took it to a ford garage and got told it was a sensor problem, so we replaced the sensor for about £160, i drove off, about 2 days later same problem, took it back and this time was told it was the whole cluster, so replaced the clustor for £500.

No.2. i mostly drive on motorways, and gradualy i noticed the car was losing its power, naturally i thought, better get it serviced, so i took it to the same ford garage and gave it a full service for £230, this did nothing. infact it was worse, i was told from the service that the flywheel was on its way out and was giving a quote for £1,500 and there were oil leaks, i thought my god, over half the worth of the car itself, but i had my suspisions, this seemed to come out of nowhere and im not sure if it is the actual problem considering they have got it wrong before. i wanted a second opinion...

No.3. was on a motorway and a lorry had a blow out of its back tire and it took the rear of the lorry with it, there was debry everywhere! i had cars to my right, my left and behind me, i could only hit this debry as best i could with the speed i was going, i think a bit of tire or bumper took out my intercooler, leaving a massive hole in it, i pulled over to check the damage, nothing was leeking and could only see a dent in the intercooler at the time, the car had no difference to the way it drove, so i went home, as i was on my way it went into limp mode and the engine systems fault light appeard.

No.4. this time i took it to a small private garage with good reveiws in my area, we noticed the intercooler had a big hole in it and was no longer funcional, we replaced it for £225. the car was still in limp mode however and would not rev above 3000rpm so could not do a restart, i also had leaking injectors. we bench tested the injectors and they were all fine but had to replace the seals, and forced it to do a system restart which kicked out so must soot we had to evacuate the garage for 2 hours. we then drained and replaced the oil. all in all it cost me £550 but the car thank god has its power back and works....

No.5. i have always noticed my engine when turning it off it rattles and judders quite badly, i no diseals are prone for this but this seems to be a bit to much and its getting slightly worse as time goes on, also the car shakes quite badly too when stationary, any ideas ??
anway i was driving on the motorway when out of nowhere the engine system fault light pops on again, i thought huh ? no loss of power, car is running fine, now what !?!
took it back to the private garage and done another restart but it hasn't helpped, maybe its the dpf filter has got so clogged from not having a intercooler.. but surely i drive on motorways and had 2 system restarts it should be pretty damn cleaned out for a car thats done 80,000miles on mostly motorways, i was given a quote for £580 to change it, but then again i think what if its not that, the car has had no loss of power and not gone into limp mode so what if it is this damn flywheel. i dont want to pay out any more damn money for something i don't need.

sorry its a bit of an essay but i asure you its easier to read it than live it. any ideas would be much appriciated !!
i also forgot to mention the breathing pipe keeps comming off too.