Help - Search - Members - Calendar
Full Version: Focus Zetec Diesel Battery Light Issues
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
qwerty1982
Hi, i have recently had a new battery and alternator fitted in the last couple of months. The other day, after driving for about 5 minutes i noticed the battery light had come back on, the car was functionally like normal though. I stopped, turned off the engine and then restarted and it went away. It was then fine for a couple of days.
Then one morning, I started the engine, reversed and stalled. When i restarted the engine it was like the throttle had gone, when ever i pressed on the accelerator there was nothing and after a few seconds the engine would stall. It did this about 5 times in a row until i opened the bonnet. Not having a clue i closed the bonnet and tried to start again, this time she started fine and has worked fine since.
Then this morning, she started fine, drove off down the road and after about 30 seconds the battery light had come back on, again car functional normally. Stopped, restarted and all was ok.

What could cause this?
Any one have any idea at all?
qwerty1982
Well touch wood it has not happened again since posting this message.
Does any one have any ideas?
salsheikh
check for any loose battery earthing points. happened to me in a previous car where 1 lead was loose and the car wouldnt start, called RAC out who identified the loose cable.
Stoney871
Get a cleaning tool for your battery terminals.
Give them a good scrub and see how you get on.
If that doesn't cure it then check the earth strap.


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.